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LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

LibreCAD is a free Open Source Computer Aided Drafting (CAD) application licensed under GPLv2.

The latest information about LibreCAD can be found at librecad.org.

** LibreCAD User Manual - PDF **

The PDF conversion process on Read the Docs has limitations that affect the PDF version of this document. Our
best efforts has been made to address those limitations where possible, but some issues with tables and images/figures
remain.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.
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CHAPTER

ONE

ABOUT

LibreCAD, the web site, wiki and the User Manual are all user supported and represents the efforts numerous volunteers
committing countless hours of time to create, improve and support the application and documentation. Support is free
directly from the large dedicated community of users, contributors and developers.

1.1 The Application

1.1.1 History

LibreCAD is a free Open Source 2D CAD application using the cross-platform framework Qt. That means it works
with multiple operating systems; Windows, Apple and Linux.

The project started around 2010 as a fork of QCAD 2.0.5.0. It began as a project to build CAM capabilities into the
community version of QCAD for use with a Mechmate CNC router. This gave rise to CADuntu. The project was
known as CADuntu only for a couple of months before the community decided that the name was inappropriate. After
some discussion within the community and research on existing names, CADuntu was renamed to LibreCAD.

Since QCAD CE was built around the outdated Qt3 library, it had to be ported to Qt4 before additional enhancements.
Porting the rendering engine to Qt4 proved to be a large task, so initially LibreCAD, the 1.0.0 series, still depended on
the Qt3 support library. Thanks to our master developer Rallaz, the Qt4 porting was completed during the development
of 2.0.0 series and LibreCAD has become Qt3 free. The latest version of LibreCAD, the 2.2.0 series, requires the Qt5
framework.

1.1.2 Features

LibreCAD has the following features:

• reads DWG and DXF files

• writes DXF, SVG, PDF, and more. . .

• drawing entities include line, polyline, spline, circle, ellipse, text, dimension, blocks and hatches

• advanced snapping system

• custom toolbars and menus

• highly customizable user interface

• plugin system

As free software you can redistribute it and/or modify it under the terms of the see GNU General Public License version
2 (GPLv2) as published by the Free Software Foundation.
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1.2 The User Manual

The user manual is a compilation from many sources. The manual includes detailed instructions on obtaining, installing
and configuring LibreCAD in the Getting Started section. It contains the technical descriptions of the tools, functions,
widgets, etc. in the Reference section and generic instructions on how to do a few things with LibreCAD in the User
Guide section. There is also further information and links to additional resources in the appendices.

The manual is best viewed with a minimum screen width of about 1100 pixels to display the menu and content in a
browser. Clicking the “LibreCAD” text or icon at the top of the menu will return to the User Manual’s home page.
On smaller devices, such as a mobile device, a minimum screen width of 800 pixels is recommended to display to
content. At screen resolutions of 800 pixels or less, the navigation menu is hidden. It can be made visible by clicking
the “hamburger” icon. Clicking the “LibreCAD” text top of the window will return to the home page.

This manual uses screen captures of LibreCAD installed on Linux. While the images may appear slightly different on
Windows or MacOS, the application layout and menu commands will be the same.

1.2.1 Conventions

• Internal and external links appear in blue.

• Clicking on the embedded images will display them full size. Click the browser’s “back button ” to return to the
manual.

• Application menu paths are shown in bold and levels are separated with “->”, e.g. File -> New.

• Dialogue box titles are shown in bold with matching case.

• Dialogue box labels are enclosed in quotes, ” ”, with matching case.

• Tab titles are enclosed in quotes with matching case.

• Button labels are enclosed in quotes with matching case.

• Key combinations are shown with the keyboard labels enclosed in square brackets with a “+” between keys, e.g.
[Ctrl]+[C].

• Text typed at the command line (OS commands, CAD commands or coordinates) is shown in a text box:

li
0,0
0,50
k

1.2.2 Contributors

There are many people who have contributed to the LibreCAD User Manual. Those contributions have come via
LibreCAD’s forum, wiki and source code.

Some of those that have contributed, directly or indirectly, include:
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Armin Stebich Bob Woltz
Chris G Clive Tubb
David Huff dellus
Dli, Fabrice
Ferdi Gary S (Maintainer)
R. van Twisk Ravas
Richard M Brown Stano Sitar

1.2.3 Copyright

This work is licensed under the Creative Commons Attribution 4.0 International License. To view a copy of this license,
visit http://creativecommons.org/licenses/by/4.0/ or send a letter to Creative Commons, PO Box 1866, Mountain View,
CA 94042, USA.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.
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CHAPTER

TWO

GETTING STARTED

LibreCAD is available for multiple operating systems and from a variety of sources. It can be used “straight out of the
box” or can be customized to suit the user’s preferences and needs.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

2.1 Download and Install

LibreCAD is available as two variants; as a stable version (i.e. general release), or as a unstable (also referred to as
“daily” or “nightly” depending on the repository) release. The stable version is recommended for most users. The un-
stable build represents the cutting edge of LibreCAD development and might contain bugs or new, incomplete features
under development. Those new features may or may not be included in next general release version. LibreCAD can
also be built from the source code so users can compile the most current code base for their OS / platform.

2.1.1 Windows

Links to the MS Windows installers can be found in the Resources section of the appendix. Download the desired
version, stable or a “NightlyBuild” of the installer from the build directory and run the installer (exe file).

2.1.2 Mac OS/X

Links to the installers for OS/X 10.9 can be found in the Resources section. Download the desired version of the
installer from the build directory and run the installer (dmg file).

For other versions of OS/X, please follow build instructions in the appendix.

Note: If you are an OS/X developer, please help us improve the DMG installers and MacPorts LibreCAD package.

7
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2.1.3 Linux

LibreCAD is available in the software repository of many Linux distributions, however the versions in the repositories
may not be the most recent release of LibreCAD. Some distributions may have community supported builds that may
be more recent than what is available in the official software repository.

Packages are available for the following Linux distributions through their respective repositories:

• Debian (Stable and Unstable)

• Ubuntu (Stable and Daily PPAs)

• Arch Linux

• Fedora

• Gentoo

• OpenSUSE

Links to the repository can be found in the Resources.

Ubuntu

Official Ubuntu Repository

LibreCAD can be found in Ubuntu’s “Software Center” for Ubuntu 11.04 (Natty) and later. Search for “librecad” in
the software manager and then download and install it for your system, or to install it from the command line type:

$ sudo apt-get update
$ sudo apt-get install librecad

Debian

LibreCAD is available in the main repository of Debian 7.0 (Wheezy) and later. Use your favorite package manager
(e.g. aptitude, synaptic, etc.) and search for “librecad” to install and configure it, or simply from the command line
type:

$ sudo apt install librecad

Debian Unstable

If you are not running unstable (i.e. Sid), and still want to upgrade LibreCAD to a newer version unstable package,
download the LibreCAD debs from “Debian unstable” (Resources), and manually install them in your system by “dpkg
-i”:

$ sudo dpkg -i /path/to/librecad_1.0.0~rc3+nolibs-1_i386.deb
$ sudo dpkg -i /path/to/librecad-data_1.0.0~rc3+nolibs-1_i386.deb

8 Chapter 2. Getting Started



LibreCAD User Manual, Release 2.2.x.y

2.1.4 Other

FreeBSD

LibreCAD is available from [ports], and can be installed as a binary package:

# pkg install librecad

2.1.5 Build from Source Code

For the most current up-to-date version of LibreCAD with the latest enhancements and fixes, it can be built for source.
the instructions are in the Build from Source section of the appendix.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

2.2 Configuration

2.2.1 Initial Setup

LibreCAD’s “Welcome” dialog is shown the first time LibreCAD is launched after installation. The dialog prompts the
user to select the Default Unit and the languages to be used for the GUI and for the commands:

LibreCAD then starts with its default configuration and is ready use. Additional configuration as required can be
completed by changing the Application Preferences as shown below.

2.2. Configuration 9
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2.2.2 User Interface

The user interface consists of several major elements:

LibreCAD’s default applications window

• Menu: provides access to application functions (open, close, etc.) and drawing tools. Menus can be customized
to suit user preferences. Refer to Application Menu in the Reference section.

• Toolbars: provides access to drawing tools and functions. Refer to Toolbars.

• Docks: provides access to drawing tools and functions. Refer to Docks.

• Status bar: displays information about current drawing operation. (See below.)

• Drawing window: displays the active drawing.

10 Chapter 2. Getting Started
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Status Bar

There are five sections in the status bar. Those sections displays information about current drawing operation and
include coordinates, prompts for the next action, information about the selected entity or entities, and the grid status.

Section Description
Coordinates Displays the absolute coordinates (left) and the relative coordinates (right) of the cross-hair /

cursor. Cartesian coordinates are shown on top and and polar coordinates are bottom. Refer
to Coordinates in Fundamentals of the Reference section for more details on the type of
coordinates.

Next Action Displays a prompt for the next action required for the current command; e.g. ”Specify next
point”, ”Specify center”, etc. Prompts to the left of the mouse icon represent left mouse
button actions and the right represent right mouse button actions.

Selected Display the total number and the combined lengths of one or more selected entities.

Current Layer Displays the active layer. Refer to Layers in Fundamentals of the Reference section for
more details.

Grid Displays the minor and major grid spacing for the X and Y axes. Minor grid spacing is
represented by dots, and the major by dotted lines.

2.2. Configuration 11
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Layout

LibreCAD’s layout and appearance is highly configurable:

• Menus: drop down from the menu bar or can be “torn off” and float anywhere on the display. Click the dashed
line at the top of a menu to detach it.

• Toolbars: can be dragged and dropped to the top, bottom, left, right, or float anywhere on the display.

• Docks Widgets: (e.g. command line or layer list) can also be dragged and dropped to the top, bottom, left, right,
or float within the drawing window. In addition they can be stacked in the same region of the application window
where they will be “tabbed”. Optionally docks can be placed outside of the application window, such as when
using multiple monitors. Drawing tools are also available as dock widgets, but are suited as floating “toolboxes”.
Widgets can also be resized by dragging their edges.

• Style sheets: allow users to change the visual elements of the application’s window decorations; title bars, fonts,
colors, etc. Refer to the Customizing in the Reference section for more details.

Fig. 1: LibreCAD applications window - custom layout

12 Chapter 2. Getting Started
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2.2.3 Application Preferences

In addition to the layout, LibreCAD has many preferences that will change other aspects of the appearance or behavior
of the application. The preferences can be configured by selecting Options -> Application Preferences. Different
elements of the preferences can be set; Appearance, Paths and Defaults.

Appearance

There are three categories on the “Appearance” tab that allows the
user to change the look and behavior of LibreCAD.

The Graphic View category has options for the snap indicator style
and shape, scroll-bars and grid. Use the Snap Indicator Lines to se-
lect the style for orthogonal (Crosshair, Crosshair 2 or Spiderweb)
or isometric (Isometric) projections. The Anti-alias setting, if sup-
ported by the hardware, when checked will reduce jagged edges of
diagonal lines, circles, etc.

The Language categories allows the the user to select the language
used in the GUI and command line. Supported languages can be
found in the appendix.

Thirdly, the Graphic Colors section allow custom colors to be se-
lected for the snap indicator, drawing background, grid, and other
indicators (selections, highlighted items and Handles). Users can
select predefined colors from the drop down menu or select their own from the color selector.

Path

The Path tab allows users to specify the directory paths to additional
resources; language (“Translations”) and user created or installed
Hatch Patterns, Fonts, Parts libraries and Templates and a “Vari-
able file”. These paths do not override the defaults paths, but are
appended so the default resources are still available.

It is recommended that user defined resource be placed in a user di-
rectory (e.g. home directory on Linux: ~/LibreCAD/Translations,
etc.)

• Translations: Language files for the GUI and / or command
languages.

• Hatch Patterns, Fonts, Parts Libraries: user created or ob-
tained from other sources such as the Parts Library wiki

• Template: specify the full path and filename of a user-defined
drawing template to load when launching the application or
starting a new drawing

• Variable File: load a user-defined variable file when starting
the application (see the Command Line guide for details on
using commands / variables files.)

2.2. Configuration 13
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Defaults

The Defaults tab allows users to specify application-wide defaults.

Drawing Defaults

Unit: Defines the default unit of measure for all new drawings.
The default can be overridden by setting the unit of measure in the
Drawing preferences or template.

Program Defaults

• Auto backup: When checked, a backup will be created when
closing the file. Backup files are saved to the same directory
as the drawing file with a tilde (~) appended to the file name.

• Auto save time: The time in minutes to perform an automatic
save of the open files. Auto files are saved to the same direc-
tory as the drawing file with a hash symbol (#) prefixed to
the file name.

• Don’t use native OS file open dialog: When checked, Li-
breCAD’s file open dialog is displayed when opening files.

• Modify layer of selected entities, at layer activation: If
checked, entities can be assigned to a layer by selecting the
entities and then selecting the destination layer.

Clear Settings

LibreCAD’s configuration can be partially or entirely reset back to a defaults:

• Layout: Resets the application window layout to the default configuration.

• All: Resets the application to the default configuration. Window layout, color settings, custom menus and tool-
bars, etc. are all reset. The “Welcome” dialog will be displayed next time the application is launched.

Startup

When checked the following items will:

• Display loading screen: LibreCAD’s load screen (e.g. splash screen) is displayed when launching the application.

• Start in tab mode: the drawing window is tabbed (same as selecting Drawings -> Tab mode from the main menu).

• Start with main window maximized: LibreCAD will start with the application window full screen.

• Enable CAD dockwidgets: show drawing tools (Circle, Curve, etc.) in the widget menu (Widgets -> Dockwid-
gets)

• Enable CAD toolbars: show drawing tools (Circle, Curve, etc.) in the toolbar menu (Widgets -> Toolbars)

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.
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The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.
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CHAPTER

THREE

REFERENCE

The Reference section provides an explanation of LibreCAD’s user elements, commands, drawing tools and other
features that are needed to create and print drawings. The reference manual provides a brief description of the command
and what parameters are necessary.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

3.1 Fundamentals

To be able to use LibreCAD effectively, there are a few concepts that need to be understood. While a basic drawing or
sketch can be created after the initial setup, as drawings become more complex further consideration to the elements
of a complete drawing is important. This section offers an introduction to some concepts that are required to create a
drawing, but by no means is it exhaustive. The rest of the Reference section provides a description of the tools used to
configure, create and modify drawings. Further general examples and guidance is offered in the User Guide section.

LibreCAD supports two drawing perspectives; orthogonal and isometric projections. Orthogonal projection is the
default perspective for creating two dimensional (2D) drawings. An isometric projection allows LibreCAD to represent
a three-dimensional object in two dimensions, sometimes referred to as “2.5D”. Both projections use coordinates to
locate drawing elements.

3.1.1 The Coordinate System

Understanding the coordinate systems and how coordinates work in LibreCAD is necessary to produce precise draw-
ings. Points are used to describe an aspect of an entity (e.g. the end of a line, the center of a circle, etc.), and can be
placed accurately using coordinates.

There are two coordinate systems used in LibreCAD to place a point in a drawing. A point can be placed by specifying:

• a horizontal distance and vertical distance from a reference point (Cartesian), or

• an angle and distance from a reference point (Polar).

All coordinates in a drawing are relative to the origin or absolute zero. It is where the X and Y axes cross each other
and is represented by crossed red lines. The coordinates of this point are 0,0. Coordinates to the right and above the

17
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origin are positive. Coordinates to the left or below are negative. Every entity drawn can be located in relation to the
origin.

LibreCAD also uses a Relative Zero point. It is the last point set having created an entity. It is represented within the
drawing by a small red circle with a cross in it. The Relative Zero point is set temporarily to a new position in a drawing
so that a subsequent coordinates of the next entity can be placed using relative coordinates.

Angles

Angles are also used in LibreCAD. While horizontal or vertical distances are measured in the specified unit, angles in
LibreCAD are always measured in degrees, beginning from 0 degrees horizontally to the right of the origin, or at the
3 o’clock position. Angles entered as a positive value are measured in an anti-clockwise direction. Angles entered as
a negative value are measure in a clockwise direction.

18 Chapter 3. Reference
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Types of Coordinates

Cartesian

The Cartesian coordinate system is commonly used in most CAD programs. Cartesian coordinates take the form X,Y
where X is measured along the horizontal axis and Y on the vertical axis. Coordinates can also be shown as “positive”
(+) or “negative” (-) values. A specific point in a drawing is located by exact distances from the X and Y axis - for
example a point in a drawing could be “100,75”, as shown here.

Polar

The Polar coordinate system uses a distance and an angle to locate a point in a drawing. In LibreCAD the < symbol
is used to designate an angle when using polar coordinates. Polar coordinates take the form 100<45, indicating a line
100 units long and with an angle of 45 degrees as shown.

3.1. Fundamentals 19
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Defining Coordinate Locations

In LibreCAD lines, points, arcs, polylines, circles, and many more entities can be placed in a drawing using either
absolute or relative coordinate input.

Absolute

When using absolute coordinates, whether Cartesian or polar, points are entered in direct relation to the origin (0,0).
To do this in LibreCAD enter in the desired point, e.g. “100,75” or “100<45” as shown in the two images above.

Relative

The next point can also be placed relative to the previously placed point. The last point placed when creating an entity
becomes a temporary reference for the next point. The newly set temporary reference is the “Relative Zero point” and
the next coordinates can be entered relative to that point. To define the next point relative to the Relative Zero point,
either cartesian or polar, prefix the coordinates with the “@”. Points without the @ prefix are always interpreted as
absolute coordinates.

For example, when using cartesian coordinates to set a point 75 units to the right and 65 units above of the previous
point, use “@75,65”. In the example shown, the previous point was set at 25 units horizontally and 35 vertically (25,35)
from the origin (0,0). The next point can be set @75,65 from the Relative Zero point at 25,35, resulting in a point at
100,100 absolute (100 units horizontally and 100 vertically from the origin).

Hint: Relative coordinates can also be entered using the x..y format. This format is equivalent to prefixing the
coordinates with the @ symbol, but allows for numeric keypad input when using the command line. As an example,
entering coordinates as 75..65 is equivalent to @75,65.

Fig. 1: Absolute & Relative Cartesian Coordinates

As an example when using a polar coordinates, to place a point 100mm and 45 degrees from the last point drawn at
25,35 (absolute cartesian coordinate) use “@100<45” (relative polar coordinate).

20 Chapter 3. Reference
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Fig. 2: Absolute Cartesian & Relative Polar Coordinates

3.1.2 Entities

An entity is a geometric shape; a line, circle, arc, etc. A collection of entities is what forms a drawing. In addition
to the basic information that describes the geometry of an entity, there are two more attributes that further define an
entity:

• Pens describes the appearance of an entity, either on screen or in printed output with three additional properties:

– Color

– Width

– Line Type

• Layers provide a means to organize drawing and manage the properties of multiple entities.

Note: Pen or Layers properties can have a specific meaning, but vary by industry or an organization’s standards and
a complete description is beyond the scope of this manual.

Pen

As with many other aspects of drafting line color, thickness and type assigned to an entity, such as a line or circle are
determined by drafting conventions or common practices. Within LibreCAD, the three attributes are grouped together
as a “Pen”:

• Color - LibreCAD has 16 default colors, but supports the RGB color space (#000000 to #FFFFFF or 16,777,215
colors). The initial color for entities is black.

• Width - The default line width is 0.00mm. Line widths of up to 2.11mm are supported.

• Line Type - The default line type is “Continuous” (e.g. solid). Other line types included with LibreCAD are
Dot, Dash, Divide, Center, and Border.
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The pen attributes can be defined for a single entity (via the Properties tool) , by a group of selected entities (via the
Attribute tool), or by layer.

Note: Just as with entities, “pens” can also be applied to layers. See Layer List Dock for details on setting a layer’s
attributes.
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Color

The color for an entity can be selected from the ”Color” selection drop-down menu. The
drop-down menu allows the color to be selected ”By Layer”, ”By Block”, from the ”Custom”
color selector, or chosen quickly from one of the 16 pre-defined colors:

Selecting ”By Layer” will assign the color that was defined for the layer (see above) to the
entity. If the layer’s selected color is subsequently changed all entities on the layer will be
assigned the layer’s color.

When editing a block, selecting ”By Block” will assign the color that was defined for the
block to the added entity. If the block’s color is subsequently changed all entities in the block
will be assigned the block’s color.

Selecting ”Custom” will allow a selection from a palette of 36 colors and shades of grey or
from a user defined colors. User defined colors are created by clicking the Add button
and then selecting the hue and value from the color selection tool. User defined colors can
be modified by right-clicking on a user defined color and selecting a new hue and value. A
maximum of eight user defined colors can be added.
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Width

The LibreCAD default line thickness is 0.00 mm (hairline) and range up to 2.11 mm. The
range include ISO standard width lines. Line widths vary by purpose; outline, hidden, sec-
tion, etc., and by drawing size; larger drawings utilize thicker lines. In addition to the line
widths, four additional options will show on the drop-down list:

• - Unchanged -: Leave the line width as previously selected.

• By Layer: Adopts the line width set in the layer’s attributes.

• By Block: Adopts the line width used when the block was created.

• Default: Returns the line width to the default (0.00 mm).

Refer to Common Line Widths in the appendix for examples of line thickness by purpose.
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Fig. 3: Available Line
Widths (Attributes)

Line Type

LibreCAD includes several commonly used line types:

Line Type Example Purpose

Continuous Object or visible, dimension, extension and construction lines.

Dot

Dash Hidden lines and phantom lines (long dash).

Dash Dot

Divide Marks location (cross) section of object.

Center Marks center of circle, arc or any symmetrical object.

Border Used for drawing border around perimeter of sheet.

Other than ”Continuous”, the other non-continuous lines are available in default, ”tiny”
(1/6x default), ”small” (1/2x) and ”large (2x)”. As with line thickness, different types
of lines are used for different purposes. A complete list of line types are shown in the
appendix.

Note: Intervals for non-continuous line types with white spaces remain constant when scaled. ”Tiny” should be used
in most cases.

Layers

One of LibreCAD’s key features is the ability to use layers. Layers help organize draw-
ings by allowing users to place and manage related entities. Traditional manual drafting
used a similar approach. The layers were often drawn on separate transparent sheets of
paper. These sheets were then overlaid one on top of another to produce final drawings.

Whether for engineering, architectural, construction, manufacturing or other types, lay-
ers were used to show different aspects on the drawing. Layers could be added to show
centre lines or dimensions on an engineering or manufacturing drawings, or to show
different building systems on architectural drawings such as exterior walls, partitions,
electrical, HVAC, grid lines, etc. While one layer can contain multiple entities, every
entity in a drawing can only be associated with single layer. Typically entities with com-
mon functions or attributes are put on the same layer. For example, all the walls in a
floor plan drawing would be put on a layer named “Walls”.

Layers have an added advantage that all the pen attributes can be assigned to a layer.
Every entity on that layer will adopt the attributes that have been assigned to that layer.
However, the attributes assigned by the layer can be overridden for entities if necessary.
In the above example a line thickness can applied to all entities on the “Walls” layer by
changing the “Layer Settings” for that layer.
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Creating a Layer

Layers are usually created to hold entities with common attributes. Creating a layer is
simple:

• Click the Add a layer icon .

• Specify a Layer Name.

• Optionally specify the Color, Width and Line Type for the layer.

• Click Ok.

Construction Layers

A construction layer is designed to hold geometry construction lines:

• A construction layer won’t appear on printout.

• All lines of a construction layer are infinite in length.

You can toggle between construction and normal mode three ways:

• When creating or modifying a layer, click the Construction Layer checkbox in the Layer
Settings dialog.

• Right-click on a named layer in the Layer List and choose “Toggle Construction Layer”.

• Click the “Toggle construction lines” icon / in the Layer List.

For more details on hiding, locking and deleting layers, refer to Layer List Dock in the
Dock Widgets Reference section.

3.1.3 Drawing and Editing Entities

Creating Entities

There are two methods for defining coordinates when drawing entities in LibreCAD.
Users can either use a mouse or other pointing devices, or the keyboard and enter coor-
dinates.

Using a Mouse

Entities’ coordinates can also be located graphically using a mouse or other pointing
device. Using a mouse is less precise, but may be acceptable for rough sketches or other
freehand work. However, the accuracy of using a mouse can be enhanced through the
use of snaps.
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Using the Keyboard

The keyboard can be used to select tools and enter coordinates using the command line.
Tools can be selected by typing a command and then entering the coordinate values.
The commands are shown in the Drawing Tools. Coordinates can be entered at the
command line after selecting a drawing tool using the formats as shown previously;
100,75 (Cartesian) or 100<45 (polar), absolute or relative (prefixed with @).

LibreCAD offers an additional method for entering relative coordinates when using the
numeric keypad; type two decimal points .. in lieu of the comma between the X and Y
values. For example, 10..20 is equivalent to typing @10,20. Refer to the User Guides
for more details on using the command line.

Hint: The command line also accepts arithmetic expressions in coordinate values; e.g. 100<45+15 is a valid input
for a 60° polar coordinate. For more details see The Command Line section or Calculator appendix.

Text input may also be required for Tool Options where distance, angle, etc. are needed
with some of the Drawing Tools.

Selecting Entities

Selecting entities allow them to be modified or deleted. Some operations can be applied
to groups of selected entities and other can only be applied to one entity at a time. There
are a variety of ways that entities can be selected:

• Single click on an entity. Holding the [Shift] key while clicking will allow additional
entities to be selected.

• Click and drag a selection box:

– Left to right while moving down or up to select entities enclosed within the selection
window’s boundary (blue selection box).

– Right to left while moving down or up to select entities enclosed within the window’s
boundary and crossed by the selection boundary (green selection box)

• type “sa” at the command line to select all entities.

Deselect selected entities by typing “tn” at the command line or pressing [Esc]. Note
that it might be might be necessary to press [Esc] twice if a command it active.

Also see the Select tools for additional methods to select and deselect entities.

Entity Handles

Selected entities display “handles”. Left-clicking on and dragging a handles allow the
entities to be manipulated; lengthened, moved or enlarged depending on the type of
entity:

• Entities that consist of a single segment, such as lines, arcs and polyline segments, have
a start handle and an end handle. Either handle can be clicked on and dragged into a
new position.

• Handles on circles or other entities that consist of multiple segments allow it to be ma-
nipulated in a variety of ways depending on the type of entity. For example:
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– A rectangle’s corner handle can be dragged to a new position creating other quadrilat-
erals.

– A circle’s perimeter handle can be dragged to increase or decrease the diameter.

– The end points on the edges of a polygon can be repositioned.

– Dimension text can be moved, or dimension and extension lines can be repositioned by
dragging a handle.

Ordering Entities

Entities are drawn on a 2D plane, but can overlay each other and have levels that are
independent of layers. Entity can be raised, moved up, or lowered, moved down, with
respect to other entities. Each layer can contain entities that are at different levels. Use
the commands in Tools -> Modify -> Order to move entities up or down.

Action Key Result
move to top [Home] Moves the selected entity to the top most position.
move to bottom [End] Moves the selected entity to the bottom most position.
raise over entity [Page Up] Moves the selected entity up one relative position.
lower after entity [Page Down] Moves the selected entity down one relative position.

3.1.4 Isometric Drawings

Fig. 4: Isometric X, Y ,Z Axes

LibreCAD can also be used to create drawings with an isometric per-
spective. Creating isometric drawings is similar to creating orthogo-
nal drawings, but with an additional consideration towards combining
multiple views in a single perspective. Instead of the two axes (X,Y)
used with orthogonal drawings, isometric drawing are represented in
a two dimensional drawing on three axes (X,Y,Z) with 120 ° between
each axis.

See Drawing an Isometric View in Drawing and Editing section of
the User Guide for details on configuring LibreCAD for isometric
drafting.
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LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the
latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

3.2 Main Menu

Most of LibreCAD’s commands are accessible through the menu bar. Drop-down menus provides access to file and
print operations, application and drawing configurations, drawing and editing tools, and other functions.

The drop-down menus can be changed into a floating menu. Each drop-down menu has a dashed line at the top. Clicking
the dashed line allows the menu to be “torn off” and moved to another location anywhere on-screen. Clicking the x on
the upper right corner of the floating menu closes it.

Hint:

The windows top bar is created and handled by your operating system.
Thus appearance and handling may vary.
If just click doesn’t work, try to drag the dashed line to create the floating menu.
The x may be any other symbol and it may also be on the left side, just follow your intuition and close the menu like
any other window on your system.
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3.2.1 File

Menu Item Icon Short-cut Description
New [Ctrl]+n Creates a new drawing file.
New from Template Creates a new drawing file from a template. See Templates in User

Guides for details.
Open [Ctrl]+o Open existing drawing file.
Save [Ctrl]+s Save current drawing file.
Save as [Ctrl]

[Shift]+s
Save current drawing file to a different location or with a new file
name.

Import Import a block, or bit mapped or vector images into the current
drawing. Supported bit mapped formats include: bmp, cur, gif,
ico, jpeg, pbm, pgm, png, ppm, xbm, and xpm. Vector images
supported include svg, and svgz.

Export Export the current drawing as a CAM, pdf or image file. Sup-
ported bitmapped formats include: cur, jpeg, pbm, pgm, png,
ppm, bmp, ico, xbm, and xpm. Vector images supported include
svg, and svgz. Use the ‘’CAM” export to save SVG (Scalable Vec-
tor Graphics) suitable for MakerCAM, EleskCAM, LaserWeb, . . .

Print [Ctrl]+p Produce output of the current drawing. See Printing in the User
Guides section.

Print Preview View output on screen of the current drawing.
Close [Ctrl]+w Close the active drawing.
Quit [Ctrl]+q Close the application.
Recent Files Open existing drawing file from a list of previously opened draw-

ing files.

3.2.2 Options

Menu Item Icon Short-cut Description
Application Prefer-
ences

See Application Preferences in Getting Started for details.

Current Drawing
Preferences

See Drawing Preferences for details.

Widget Options See Widget Options for in Customizing details.
Device Options Select input device: mouse, tablet, trackpad or touchscreen.
Reload Style Sheet [Ctrl]+t See Style Sheets in Customizing for details.
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3.2.3 Edit

Menu Item Icon Short-cut /
Command

Description

Selection Pointer [Esc] / k, kill Reverts from current operation to the selection pointer (e.g. can-
cels the current operation)

Undo [Ctrl]+z / u,
undo, oo

Sequentially reverses the previous operations.

Redo [Ctrl]+[Shift]+z
/ r, redo, uu

Sequentially reverses the previously reversed operations.

Cut [Ctrl]+x Removes the selected entity (or entities) and places it in temporary
memory, e.g. ‘’clipboard” for later recall. A reference point needs
to be placed for subsequent paste operations.

Copy [Ctrl]+c Creates a copy of the selected entity (or entities) in temporary
memory to be recalled. A reference point needs to be placed for
subsequent paste operations.

Paste [Ctrl]+v Recalls the entity (or entities) from temporary memory and place
it at a location defined by a reference point.

Delete Selected [Del] Removes the selected entity (or entities) from the current drawing.

3.2.4 View

Menu Item Icon Short-cut /
Command

Description

Fullscreen [F11] Hides the application title bar and toggles LibreCAD to use the
entire display.

Statusbar [Ctrl]+[I] Toggles the visibility of the status bar at the bottom of the appli-
cation window.

Grid [Ctrl]+[G] Toggles the visibility of the grid.
Draft [Ctrl]+[D] Toggles to or from ‘’Draft Mode”. Draft mode displays hatches as

invisible, and only displays bounding boxes for images and text.
Drawings will display faster, particularly on slow computers.

Redraw [Ctrl]+[R] / zr,
rg, regen, re-
draw

Refreshes the view of the current drawing.

Zoom In [Ctrl]+[+] Increase view of drawing by 25% increments.
Zoom Out [Ctrl]+[-] Decrease view of drawing by 20% increments.
Auto Zoom za Resize the view of the drawing to fill the drawing window.
Previous View zv Revert to the previous zoom level of the drawing.
Window Zoom zw Increase the view of the selected area to fill the drawing window.
Zoom Panning zp Move the view of the drawing in the window.
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3.2.5 Plugins

Menu Item Icon Short-cut Description
Align Align selected entities to a reference by defining the final positions

of 2 initial points.
Read ascii points Read points from a text file. Each line of the file is a point defined

by an ID, X coordinate, Y coordinate, Z coordinate and an optional
code. Each field can be separated by a comma, a tab or a space.
The decimal separator is the point (.). The points can be connected
with a line, ID, or coordinate and code fields can be plotted as text.

Divide Divide a line or a circle with n sections. A tick can be located at
the limit of each section to show each limit. The size of this tick
can be defined as a percentage of the segment length. The line or
the circle can be broken at the limit of each section using Divide
tool.

Gear plugin Draw a gear by selecting the center of gear and defining parameters
such as number of teeth, modulus, etc.

ESRI Shapefile Import GIS geospatial vector data shapefile (i.e. maps). Warning:
The import process will lock LibreCAD until it is complete and
large files can be very time consuming.

List entities List the selected entities along with their properties such as ID,
layer, color, line type, line thickness, coordinates.

Read PIC file Import Pic graphics language diagrams.
Plot plugin Plot a mathematical function or a parametric function using the

drawing coordinate system. The formula, start value, end value
and step value are required. The plot can be lines, a polyline or a
spline.

Same properties Apply the properties of a reference entity to selected entities. The
modified properties are layer, color, line type and line thickness.

Sample plugin Draw a line by specifying the X and Y coordinates of end points.

3.2.6 Tools

See Drawing Tools for a description of the drawing tools.

3.2.7 Widgets

Menu Item Icon Short-cut Description
Dock Areas Toggles the visibility of the left, right, top, bottom and /or floating

Dock Widgets.
Dock Widgets See Dock Widgets for descriptions.
Toolbars Toggles the visibility of the toolbars.
Menu Creator Create custom menus. See Menu Creator in Getting Started for

details.
Toolbar Creator Create custom toolbars. See Toolbar Creator in Getting Started

for details.

32 Chapter 3. Reference



LibreCAD User Manual, Release 2.2.x.y

3.2.8 Drawings

Menu Item Icon Short-cut Description
Tab mode When selected, each open drawing is in its own tabbed drawing

or preview window. Tabbed windows cannot be moved, resized or
arranged with in the LibreCAD application window. The selected
tab is the active window.

Window mode When selected, each open drawing is in its own independent draw-
ing or preview window that can be moved, resized or otherwise
arranged (see below). ”Window mode” is the default mode.

Layout Tab mode only. Allows the selection of the tab’s appearance
(”Rounded” or ”Triangular”) and the location of the drawing win-
dows tab (”North”, ”South”, ”East” or ”West” (top, bottom, right,
or left respectively)).

Arrange Window mode only. Drawing windows can be ”Maximize”, ”Cas-
cade”, ”Tiled”, ”Tiled Vertically”, ”Tiled Horizontally”

Currently opened
drawings

List the current open drawing(s). The item with the checked box
is the active drawing.

3.2.9 Help

Menu Item Icon Short-cut Description
Online Displays links to online resources; Wiki, User’s Manual, Com-

mand, Style Sheets, Widgets, Forum and Release Information.

About Displays with information about the current version of LibreCAD
and web links: to the ‘’Contributors”, License and ‘’The Code”
repository.

License Displays the license text (GNU General Public License version 2).

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.
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3.3 Drawing Tools

The drawing tools are used to create and modify entities such as lines, circles, etc. in a drawing. Commands can
be selected from the menu, toolbars or entered via the command line. Right-click anywhere in the drawing window
to display a popup menu showing the history of commands launched from the menus or the toolbars with the latest
command being on top of the list. Note that the command line input is not shown.

Several drawing tools require additional parameters and will provide prompts on the Tool Options toolbar. This toolbar
should always be enabled. If the tool options do not appear, from the menu select Widgets -> Toolbar -> and enable
Tool Options. If using the command line, the same tool options are available via the toolbar or the command line. The
tools that have options are shown in the table below.
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3.3.1 Line

Tool Icon Command Description
2 points l, li, line

Draw a line between two assigned points.

Tool Options:

Angle
Draw a line from an assigned point defining the start,
middle or end of the line and with an assigned length and
angle.

Tool Options:

Horizontal hor, horizontal
Draw a horizontal line from an assigned point defining the
start, middle or end of the line and with an assigned length.

Tool Options:

Vertical ver, vertical
Draw a vertical line from an assigned point defining the
start, middle or end of the line and with an assigned length.

Tool Options:

Rectangle rec, rect, rect-
angle Draw a rectangle by assigning the points of two diagonally

opposite corners.

Parallel
through point

pp, ptp
Draw a given number of lines parallel to a selected
existing line through an assigned point.

Tool Options:

Parallel o, pa, offset,
parallel Draw a given number of lines parallel to a selected

existing line with a given distance between lines.

Tool Options:

Bisector bi, bisect
Draw a given number of lines bisecting two existing
non-parallel lines (e.g. at an angle to each other with or
without a common point).
Tool Options:

Tangent (P,C) tanpc, tan-
gentpc Draw a line from an assigned point tangent to an existing

circle.

Tangent (C,C)
Draw a line tangent to two existing circles.

Tangent Or-
thogonal Draw a line tangent to an existing circle and perpendicular

to an existing line.

Orthogonal ortho, perp
Draw a line of a given length perpendicular to an existing
line placing the centre at an assigned point.

Tool Options:

Relative An-
gle Draw a line with a given length and at a given angle

relative to an existing line placing the centre of the line at
an assigned point.

Tool Options:

Polygon
(Cen,Cor)

pl, polyline
Draw a polygon with a given number of sides assigning
the centre point and point of one vertex.

Tool Options:

Polygon
(Cen,Tan) Draw a polygon with a given number of sides assigning

the centre point and point of the centre of one side.

Tool Options:

Polygon
(Cor,Cor)

poly2, poly-
gon2v Draw a polygon with a given number of sides assigning

the two points of one side.

Tool Options:
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3.3.2 Circle

Tool Icon Command Description
Centre, Point ci, circle

Draw a circle with a given radius by assigning a centre
point and a point on the circumference.

2 Points c2, circle2
Draw a circle with a given diameter by assigning two
opposite points on the circumference.

2 Points, Ra-
dius Draw a circle with two points on the circumference and

with an assigned radius.

Tool Options:

3 Points c3, circle3
Draw a circle assigning three points on the circumference.

Centre, Ra-
dius

circlecr
Draw a circle with a given radius centred at an assigned
point on the circumference.

Tool Options:

Tangential,
2 Circles, 1
Point

Draw a circle tangential to two existing circles and
assigning a centre point to establish the radius.

Tangential, 2
Points Draw a circle tangential to an existing circle and define the

diameter and placement by assigning two points on the
circumference.

Tangential,
2 Circles,
Radius

Draw a circle tangential to two existing circles with a
given radius.

Tool Options:

Tangential, 3
Circles

ct3, tan3
Draw a circle tangential to three existing circles and/or
lines.
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3.3.3 Curve

Tool Icon Command Description
Center, Point,
Angles Draw a curve (arc) with a given radius defined by a center

point and a point on the circumference, the direction of
rotation (clockwise or counter-clockwise), a point defining
the start position of the arc and a point defining the end
position of the arc.

Tool Options:

3 Points a, ar, arc
Draw a curve (arc) by assigning three points on the
circumference of the arc defining the start position, a point
on the circumference and end position of the arc.

Arc Tangential
Draw a curve (arc) tangential to the end of an existing line
segment with a defined radius or angle (deg).

Tool Options:

or

Spline spl, spline
Draw an open or closed spline (curve) by assigning
control points and a given degree of freedom (1 - 3).

Tool Options:

Spline through
points

stp, spline2
Draw an open or closed spline (curve) by defining points
on the spline.

Tool Options:

Ellipse Arc
(Axis) N/A

Freehand Line fhl, free
Draw a non-geometric line.
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3.3.4 Ellipse

Tool Icon Command Description
Ellipse (Axis)

Draw an ellipse by assigning a centre point, a point on the
circumference of major access and a point on the
circumference the minor access.

Ellipse Foci
Point Draw an ellipse by assigning two foci points and a point

on the circumference.

Ellipse 4 Point
Draw an ellipse assigning four points on the
circumference.

Ellipse Center
and 3 Points Draw an ellipse by assigning a centre point three points on

the circumference.

Ellipse In-
scribed

ei, ie
Draw a Ellipse constrained by four existing non-parallel
line segments.
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3.3.5 Polyline

Tool Icon Command Description
Polyline pl, polyline

Draw an open or closed continuous line consisting of one
or more straight line or arc segments defined by endpoints
and / or radius or angle for arcs.

Tool Options:

Options include Line and for curved segments; Tangential,
Tan Radius and Angle.

Add node
Add node to existing polyline. (Use “Snap on Entity” to
place new node on segment.)

Append node
Add one or more segments to an existing polyline by
selecting polyline and adding new node endpoint.

Delete node
Delete selected node of an existing polyline.

Delete be-
tween two
nodes

Delete one or more nodes between selected nodes of an
existing polyline.

Trim seg-
ments Extend two separate non-parallel segments of an existing

polyline to intersect at a new node.

Create
Equidis-
tant Polylines

Draw a given number of polylines parallel to a selected
existing polyline with a given distance between lines.

Tool Options:

Create Poly-
line from
Existing Seg-
ments

Create polyline from two or more existing separate line or
arc segments forming a continuous line.
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3.3.6 Select

Hint: When the pointer is in the shape of an arrow, i.e. no tool selected, it is, by default, in a select mode. One can
select single or multiple entities by clicking on them or select multiple entities by mean of a window:

• Drawn from left to right (blue), it will select all entities fully included in it.

• Drawn from right to left (green), it will also select intersecting entities.

Deselecting can be done by pressing the esc key, or Selection Pointer from Edit menu

Tool Icon Command Description
Deselect all tn

Deselect all entities on visible layers ([Ctrl]-[K] or default
[Esc] action).

Select All sa
Select all entities on visible layers ([Ctrl]-[A]).

Select Entity
Select, or deselect, one or more entities (default cursor
action).

(De-)Select
Contour Select or deselected entities connected by shared points.

Select Win-
dow Select one or more entities enclosed by selection window

(L to R), or crossed by selection window (R to L) (default
cursor “drag” action).

Deselect Win-
dow Deselect one or more entities enclosed by selection

window (L to R), or crossed by selection window (R to L).

Select Inter-
sected Entities Select one or more entities crossed by selection line.

Deselect Inter-
sected Entities Deselect one or more entities crossed by selection line.

(De-)Select
Layer Select or deselected all entities on the layer of the selected

entity.

Invert Selec-
tion Select all un-selected entities will deselecting all selected

entities.
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3.3.7 Dimension

Tool Icon Command Description
Aligned da

Apply dimension lines and text aligned to an existing
entity by selecting start and end points on a line segment
and placement point for the text.

Tool Options:

Linear dr
Apply dimension lines and text at an defined angle to an
entity by selecting start and end points on a line segment
and placement point for the text.

Tool Options:

Horizontal dh
Apply dimension lines and text aligned to an entity by
selecting start and end points on a line segment and
placement point for the text.

Tool Options:

Vertical dv
Apply dimension lines and text aligned to an entity by
selecting start and end points on a line segment and
placement point for the text.

Tool Options:

Radial dimradial
Apply dimension lines and text a circle’s or arc’s radius by
selecting entity and placement point for the text.

Tool Options:

Diametric dimdiameter
Apply dimension lines and text a circle’s or arc’s diameter
by selecting entity and placement point for the text.

Tool Options:

Angular dimangular
Apply angular dimension by selecting two existing
non-parallel line segments and placement point for the
text.

Tool Options:

Leader ld
Draw a text leader by by selecting start (arrow location),
intermediate and end points.
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3.3.8 Modify

Tool Icon Command Description
Order

Order entities within a layer. Selected entities can be
moved to top, bottom, raised (moved forward) over
another entity or lowered (moved backwards) behind an
entity.

Move / Copy mv
Move a selected entity by defining a reference point and a
relative target point. Optionally keep the original entity
(Copy), create multiple copies and / or alter attributes and
layer.

Rotate ro
Rotate a selected entity around a rotation point, moving
the entity from a reference point to a target point.
Optionally keep the original entity, create multiple copies
and / or alter attributes and layer.

Scale sz
Increase or decrease the size of a selected entity from a
reference point by a defined factor for both axis.
Optionally keep the original entity, create multiple copies
and / or alter attributes and layer.

Mirror mi
create a mirror image of a selected entity around an axis
defined by two points. Optionally keep the original entity
and / or alter attributes and layer.

Move and Ro-
tate Move a selected entity by defining a reference point and a

relative target point and rotating the entity at a given
angle. Optionally keep the original entity, create multiple
copies and / or alter attributes and layer.

Rotate Two
Rotate a selected entity around an absolute rotation point,
while rotating the entity around a relative reference point
to a target point. Optionally keep the original entity, create
multiple copies and / or alter attributes and layer.

Revert direc-
tion

revert
Swap start and end points of one or more selected entities.

Trim tm, trim
Cut the length of a line entity to an intersecting line entity.

Trim Two t2, tm2
Cut the lengths of two intersecting lines to the point of
intersection.

Lengthen le
Extend the length of a line entity to an intersecting line
entity.

Tool Options:

Offset o, pa, offset,
parallel Copy a selected entity to a defined distance in the

specified direction.

Bevel ch, bevel
Create a sloping edge between two intersecting line
segments with defined by a setback on each segment.

Tool Options:

Fillet fi, fillet
Create a rounded edge between two intersecting line
segments with defined radius.

Tool Options:

Divide di, div, cut
Divide, or break, a line at the selected ‘’cutting” point.

Stretch ss
Move a selected portion of a drawing by defining a
reference point and a relative target point.

Properties mp, prop
Modify the attributes of a single entity including layer, pen
color / width / line type and the entity’s geometry (varies
by type of entity).

Attributes ma, attr
Modify the common attributes of one or more selected
entities including layer, pen color / width / line type.

Explode Text
into Letters Separate a string of text into individual character entities.

Explode xp
Separate one or more selected blocks or compound
entities into individual entities.

Delete se-
lected

[Del], er
Delete one or more selected entities.
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3.3.9 Info

Tool Icon Command Description
Distance Point
to Point

dpp, dist
Provides distance, cartesian and polar coordinates between
two specified points.

Distance En-
tity to Point Provides shortest distance selected entity and specified

point.

Angle be-
tween two
lines

ang, angle
Provides angle between two selected line segments,
measured counter-clockwise.

Total length of
selected enti-
ties

Provides total length of one or more selected entities
(length of line segment, circle circumference, etc.).

Polygonal
Area

ar, area
Provides area and circumference of polygon defined by
three or more specified points.
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3.3.10 Others

Tool Icon Command Description
MText mtxt, mtext

Insert multi-line text into drawing at a specified base point.
Optionally define font, text height, angle, width factor,
alignment, angle, special symbols and character set.

Tool Options:

Text txt, text
Insert single-line text into drawing at a specified base
point. Optionally define font, text height, alignment,
angle, special symbols and character set.

Tool Options:

Hatch ha, hatch
Fill a closed entity (polygon, circle, polyline, etc) with a
defined pattern or a solid fill. Optionally define scale and
angle.

Points po, point
Draw a point at the assigned coordinates.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

3.4 Snapping

Snaps provide the ability to pick precise locations when using a mouse. Various snap tools are available to allow the
user to select different locations on entities or elsewhere in the drawing space when using the grid.
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Menu Item Icon Command Description
Exclusive Snap
Mode

On: only one snap mode is allowed. Off : multiple snap
modes are allowed The snap modes are remembered in each
state.

Free Snap os, sf Allows for the crosshair to move freely while other snap
modes are enabled.

Snap on Grid sg Snap to a grid intersection.
Snap on Endpoints se Snap to the endpoints of a line segment, the quadrants of

a circle, a point, or the alignment point of a text or mtext
object.

Snap on Entity np, sn Snap to the path of an entity.
Snap Center sc Snap to the center of a circle or ellipse. It will also snap to

the foci of an ellipse.
Snap Middle sm Snap to the middle of a path. Enabling this mode displays

a ‘’Middle points” input. If you change the value to 2 then
you can snap to the trisection points of a line segment.

Snap Distance sd If you snap to the endpoint of a line segment then activate
‘’snap distance” and input 50, then it will snap to a point 50
units from the endpoint on the line segment. However, it will
also snap to a point that is 50 units from the other endpoint.

Snap Intersection si Snap to the intersection of two entities. Note this does not
currently work for polylines.

Restrict Horizontal rh Restricts the crosshairs to the x-axis (horizontal movement).
Restrict Vertical rv Restricts the crosshairs to the y-axis (vertical movement).
Restrict Orthogonal rr Restricts the crosshairs to the x or y-axis. (either horizontal

or vertical movement).
Restrict Nothing rn Turns off restricted cursor movements.
Set relative zero po-
sition

Manually sets the Relative Zero Point at the selected coor-
dinate.

Lock relative zero
position

Locks the Relative Zero Point to the current coordinate.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

3.5 Toolbars

Toolbars provide an alternative to the menus for accessing application functions and drawing tools. See Application
Menu or Drawing Tools for complete descriptions.

Toolbars can be moved any where on the display and left floating, or docked to any of the four sides of the drawing
window, similar to Dock Widgets. Unlike Dock Widgets, icons on a Toolbar are a single row when floating or docked
to the top or bottom of the drawing window and verticle when docked to either side. Also, Toolbars cannot be resized.
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3.5.1 Drawing Tools Toolbars

Menu Item Description and/or Menu Equivalent
Categories

Groups commonly used drawing tools; Tools -> Line / Circle / Curve / Ellipse
/ Polyline / Select / Dimension / Modify and Info. Clicking an icon will display
the drawing tool in the category. See Drawing Tools for details on each tool.

Toolbar:

Circles
Drawing tools for circles. See Tools -> Circle.

Toolbar:

Creators
Access menu and toolbar creators to modify LibreCAD’s interface. Widgets ->
Menu Creator / Toolbar Creator. Also see Customizing LibreCAD’s Interface.

Toolbar:

Curves
Drawing tools for curves. See Tools -> Curve.

Toolbar:

DefaultCustom
Custom toolbar example. Includes MText, Hatch, Insert Image, Create Block,
and Points.

Toolbar:

Dimension
Drawing tools for dimensioning. See Tools -> Dimension.

Toolbar:

Dock Areas
Show or hide widgets. Widgets -> Dock Areas. See Dock Widget Areas.

Toolbar:

Edit
Edit functions; select, Undo, Redo, Cut, Copy and Paste.

Toolbar:

Ellipse
Drawing tools for ellipses. See Tools -> Ellipse.

Toolbar:

File
File operations.

Toolbar:

Info
Tools for determinig information about entities. See Tools -> Info.

Toolbar:

Line
Drawing tools for lines. See Tools -> Line.

Toolbar:

Modify
Drawing tools to modify entities. See Tools -> Modify.

Toolbar:

Order
Reorder drawing entities. See Tools -> Modify -> Order.

Toolbar:

Pen
Change entity color, width and / or line type. Pen attributes.

Toolbar:

Polyline
Drawing tools for Polylines. See Tools -> Polyline.

Toolbar:

Select
Select entities. See Tools -> Select.

Toolbar:

Snap Selection
Toggle snap tools off/on. See Snapping.

Toolbar:

Tool Options
Displays input boxes for the parameters required by the currently selected tool.
See Tool Options below. This option should always be enabled.

Toolbar:
Varies by tool selected. See Drawing Tools.

View
Toggle grid and draft mode, force redraw, and select zoom. See View options.

Toolbar:
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3.5.2 Tool Options

A variety of LibreCAD’s tools require additional parameters or have options that are shown on the Tool Options toolbar.
Several drawing tools use tool options. Those toolbars are shown in the Drawing Tools reference. Two additional
operations that require the use of the Tool Options toolbar are Print Preview and block operations.

Important: Print Preview and Block operations require the use of the Tool Options toolbar as there are no menu or
command line equivalencies. Ensure the Tool Option toolbar is enabled.

The Tool Options toolbar should always be enabled. If the tool options do not appear, from the menu select Widgets
-> Toolbar and enable Tool Options (place checkmark in checkbox). If using the command line, the same tool options
are available via a command line prompt or the Tool Options toolbar.

Print Preview Tool Options

The Print Preview Tool Options toolbar is used to set up the print output regardless of output format (pdf or paper).
The toolbar is displayed after clicking the Print Preview icon or selecting File -> Print Preview from the menu. A
combination of scale value, color status and drawing position relative to paper allows for customized print output. The
steps are detailed in printing guide.

Option Item Icon Description
Scale Displays the current scale of the drawing. The scale can also be changed to a

predefined value selected from the drop-down list, or entered as a custom ratio.
”fixed” Checking the ”fixed” checkbox locks the scale to value shown in the text-box.
Apply Print Scale to
line width

When enabled, line width is scaled on reduced drawings (drawings reduced in
size to fit a smaller page).

Toggle Black/White Toggles the colors of all entities from color to black/white.
Center to page Centers the drawing and paper to the Print Preview window.
Fit to page Fits the drawing to the margins of the paper and centers page to the Print Preview

window. (Not available when ”fixed” is selected.)
Multipages Determines the number of pages needed to print the drawing based on the defined

scale and the paper size selected in Drawing Preferences.

Block Operations Tool Options

There are two block insert operations with corresponding Tool Option toolbars. For further details on using blocks
refer to Blocks in the User Guides.
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From Block List

The Block Insert capability can be expanded through the Tool Option bar features before the block is inserted.

Option Item Description
Angle Defines the angle of rotation, if any. See Angles in LibreCAD.
Factor Defines the scale factor, if any. It is the same scale factor as in Modify.
Array Defines the numbers of columns and rows to create a pattern of selected block. Otherwise

keep 1 for columns and rows.
Spacing Defines the distance between each column of the array and the distance between each row.

The distance is measured between 2 insertion points of 2 adjacent blocks.

From Block Library

Inserting a block from a library can be enhanced through the Tool Option bar features before the block is inserted.

Option Item Description
Angle Defines the angle of rotation, if any. See Angles in LibreCAD.
Factor Defines the scale factor, if any. It is the same scale factor as in Modify.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

3.6 Dock Widgets

Dock widgets are small movable windows that serve two purposes: (1) quick access to the drawing tools, and (2) access
to additional features not available from a menu including:

• Block List,

• Command Line,

• Layer List,

• Library Browser, and

• Pen Wizard.
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Fig. 5: Drawing tool dock example:
Line

As an alternative to the Tools menu, the Dock widgets provide more convenient
way to access the Drawing Tools:

• Circle,

• Curve,

• Dimension,

• Ellipse,

• Info,

• Line,

• Modify, and

• Polyline.

3.6.1 Dock Widget Areas

Dock widgets can be moved to different areas by “grabbing” (left clicking and
dragging) the title bar of the widget and releasing it in a new location. A widget
can be left floating inside or outside of the drawing window, or placed in one
of the four dock areas (left, right, top or bottom). The Dock Areas toolbar
allows widgets to be hidden or made visible depending on their location:

Tool Icon Description
Left Shows / hide the dock widgets located on the left side of the drawing window.
Right Shows / hide the dock widgets located on the right side of the drawing window.
Top Shows / hide the dock widgets located on the top of the drawing window.
Bottom Shows / hide the dock widgets located on the bottom of the drawing window.
Floating Shows / hide the dock widgets floating within the drawing window or outside of the

drawing window.

Widgets can be placed either on top of an existing widget in any of the dock areas creating a tab for each of the widgets.
Widgets can also be place above or below an existing widget dividing the area into multiple sections.

In addition, dock widgets can be resized by clicking and dragging the edge of the widget’s box. A widget has a minimum
width of five icons and can be no shorter than the default height.

3.6.2 Block List Dock

The Block List Dock provides the functions to manage blocks and a list of blocks that are active in the drawing. Block
functions include:

Fig. 6: Block List dock example - 3
blocks
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Icon Description
”Show all blocks” - Defreeze, makes all the blocks in the current
drawing visible.
”Hide all blocks” - Freeze, hides all blocks in the active drawing.
”Create a block” - Creates a block from the selected items.
”Add an empty block” - Creates an empty block that can then be
edited is a separate window (see below).
”Remove the active block” - Deletes the highlighted block.
”Rename the active block” - Rename the highlighted block.
”Edit the active block in a separate window” - Open a new drawing
window to edit a new or existing block.
”Save the active block to a file” - Saves the highlighted block to a
file.
”Insert the active block”. - Inserts the highlighted block in the cur-
rent drawing at the specified reference point

The lower portion of the dock shows a list of blocks in the current drawing. The
blocks in the above example are named “a3”, “d1”, and “d3”. More details on
creating and using blocks can be found in the User Guides.

3.6.3 Command Line Dock

The Command Line is for users that want to draw by using keyboard com-
mands. Commands, such as “li” for a line, “cir” for a circle, etc, are entered
at the command line along with the required parameters (e.g. start and end
coordinates for a line). Using the command line can be faster and/or more
precise than drawing using exclusively a mouse and toolbars. The available
commands are listed with the Drawing Tools and Snapping tools. There are
also commands available for Edit and View operations.

Fig. 7: Command Line dock

Fig. 8: Command Line dock drop-
down menu

The dock includes a drop-down menu that offers additional functions:

• Toggle Keycode Mode off or on.

• Load a Command file.

• Paste commands.
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Further details on using the command line are in the User Guides. In addition
to command input, the command line provides access to a built in calculator.
The calculator can be invoked with the cal command. The available operators
and functions can be found in the Appendix.

Note: LibreCAD is designed with emphasis on mouse input and at the moment some options can be only selected by
using the mouse as there is no equivalent command.

3.6.4 Layer List Dock

Fig. 9: Layer List dock example with
4 layers

The Layer List Dock provides a list of layers in the current drawing and the
functions required to manage them. There are three sections in the dock:

• the list filter,

• the list operators and functions, and

• the layer operators and functions.

The list filter is the input box at the top of the dock. It provides the ability to
filter a long list of layer names to help locate a layer. Enter a text string, the
name or partial name of a layer, in the input box to filter the layer or layers.
Wildcards (”*” or “?”) can be used to filter the list to locate similar layer names
(e.g. “*01” would show all names ending by “01”).

The icons on the top of the layer list allow operations to the entire list of layers.
Those operations include:

Icon Function Description
Show all layers Defreeze, makes all the layers in the current

drawing visible.
Hide all layers Freeze, hides all layers in the current drawing.
Unlock all layer Unlock all layers to allow changes to the entities

in the layer. (*)
Lock all layer Lock all layers to prevent unintentional changes.

(*)
Add a layer Add a new layer to the list. (Shortcut [Ctrl]+[L])

(*)
Remove layer Remove the highlighted layer from the list. (*)
Modify layer
attributes /
rename

Modify the selected layer’s attributes and / or
rename the layer. (*)

The lower portion of the dock shows a list of layers in the current drawing and
are listed in alpha-numeric order. In the example above the layers are named
“Layer01”, “Layer02”, and “Layer03”. Note that layer 0 is a special layer and
should not be used for general drawing purposes.

Icons to the left of each layer act on the layers individually. The layer operations
are:

3.6. Dock Widgets 55



LibreCAD User Manual, Release 2.2.x.y

Icon Description
/ Show / hide the selected layer. (Defreeze / Freeze)
/ Lock / unlock the selected layer. (*)
/ Print / don’t print the selected layer. (*)
/ Toggle construction lines. (*) A layer designated as a ”Construction Layer” is special layer used

to create reference geometry to help align other drawing entities. Construction lines are intended
as temporary guide lines and drawn to ”infinity”.

Shows the layer’s assigned color (the default is Black).

Layer list or individual layer operations can also be accessed by right-clicking
on a layer. Right-clicking in the list window opens a popup menu that provides
equivalent operations to the item marked with an asterisk (*).

Clicking the Attribute icon allows users to change the pen attributes of all
entities on the selected layer. Entities that have their own pen attribute set
differently will override the layer’s attributes.

The attributes include:

Attribute Description
Layer Name The default layer name is “O”, but any alpha-numeric label

can be used. New layers are created with the name of the
highlighted layer with a sequence number appended. Layers
are sorted in the list alpha- numerically.

Construc-
tion Layer

Toggle the construction lines off / on.

Default Pen:
• Color: Select from default or custom colors.
• Width: Select from predefined line widths from 0.00

to 2.11 mm.
• Type: Select from predefined line types: Continuous,

or Dot, Dash, Dash Dot, Divide, Center, or Border
(normal, “tiny”, “small”, or “large”).

More details on creating and using layers can be found in the “Drawing Setup”
section of the User Guides.

3.6.5 Library Browser Dock
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Fig. 10: Library Browser dock exam-
ple

The Library Browser Dock shows blocks available from the defined libraries
and allows users to insert blocks into the current drawing. To insert a block,
select a block from one of the categories by clicking on it, e.g. “d1” and click
the “Insert” button. Specify a reference point in the drawing window with a
mouse click or by entering coordinates at the command prompt. Once inserted
into the drawing, the block is shown in the Block List Dock.

LibreCAD includes several libraries and additional libraries can be specified
by defining a path to user libraries in the Application Preferences, “Path” tab
as shown in Getting Started.

3.6.6 Pen Wizard Dock

The Pen Wizard allows users to create a palette of favorite colors for the draw-
ing tools. Colors can be selected from the existing colors via the drop-down

list or created as a custom colors via the button to the right of the drop-

down list. Pressing the “Add to favorites” [ ] button to the left will add
the color to the list of favorites below. Drag-and-drop the colors in the list to
arrange them in the preferred order.

Once colors have been added to the list, set the active pen color by double-
clicking a favorite color.

Fig. 11: Pen Wizard dock example

Right-clicking a favorite color allows users to:

• Select all objects of a specific color and clicking on “Select objects”

• Change the color of all selected objects by clicking on “Apply to se-
lected”

• Delete a favorite color by clicking “Remove”

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest
build application.

Any help is welcome to add new features and modifications to this documen-
tation, to close the gap and make the manual more complete.

3.7 Drawing Preferences

Drawing preferences have two purposes, they allow users to :

1. override the application defaults on a drawing by drawing basis.

2. define specifics for the drawing’s output, format and other drawing
specific configuration.

The preferences can be configured by selecting Options -> Current Drawing
Preferences. There are five tabs for managing the drawing preferences: Paper,
Units, Grid, Dimensions and Splines.
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3.7.1 Paper

The Paper tab is used to define the size, orientation and margins of the page used when generating output. The output
can be as a physical printed page or an electronic form such as a PDF. Layout of the page with specified settings may
be checked in Preview section. The paper format is also used when previewing a drawing (File -> Print Preview).

To be able to generate output, users must select a paper size and orientation. Paper sizes include ISO, ANSI and other
sizes. Sizes of the select page are shown in the current unit of measurement. Custom sizes can also be select by
choosing Custom from the drop-down box and specifying the paper width and height.

Orientation can be selected for any page size and is either Landscape (long edge horizontal) or Portrait (long edge
vertical).

Margins determine the printable area of a page. Specified fields at the edges of the page are marked with gray color
and always stay empty on the output.

If tiled printing is used to output the drawing, use Number of pages section to set a horizontal and a vertical number of
pages. For more details about the tiled printing refer to the Printing Guide.

3.7.2 Units

The Units tab allows users to set the Main drawing unit to the preferred unit of measure and the format of linear and
angular dimensions. The “Main Unit” setting overrides the default set during LibreCAD’s initial application configu-
ration. The same units of measures are as noted in the appendix are available for the drawing’s preferences.

Note: These preferences format the display of linear and angular units on the status bar. They do not affect the
appearance of dimensions in the drawing. See Dimensions below for configuring dimensions’ format.
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Length Format

Format Example Maximum
Precision

Description

Scientific 1.44311E+1 0.00000000E+1 Significant x 10 n

Decimal 14.43112 0.00000000 Integer part separated from the fractional part of a number by
a decimal

Engineering 1’-2.43112” 0’-
0.00000000”

Feet and decimal inches

Architectural 1’-2 7/16” 0’-0 1/128” Feet and fractional inches
Fractional 14 7/16” 1/128” Fractional inches
Architectural
(metric)

14.43112 5 0.00000000 Decimal metric units (mm, cm, etc. . . )

Angle Format

Format Example Maximum
Precision

Description

Decimal De-
grees

30.5 ° 0.00000000 Integer part separated from the fractional part of a number by
a decimal

Deg/Min/Sec 30 ° 32’ 0” 0 ° 00’
00.0000”

Degrees [ ° ] / Minutes ( ‘, 1/60 of a degree) / Seconds ( ‘’, 1/60
of a minute)

Gradians 33.9g 0.00000000g 1/100 of a right angle
Radians 0.5r 0.00000000r SI unit of measure where the arc of a circle is measured by the

length of the radius
Surveyor’s
units

N30d32’E N0d00’00.0000”ECardinal directions measure in deg/min/sec from North and
East

3.7.3 Grid

The grid provides an evenly spaced guides to assist with placing entities. When used with snaps place can be precise.
The Grid tab has the following options:

• Show Grid: Toggles the grid markers between visible or not visible. The grid can also be toggled with [Ctrl]-g
or by using the grid button of the view toolbar. This setting does not affect the use of “Snap to Grid”.
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• Grid X and Y Spacing: Sets the minimum frequency of the grid markers. Values can be selected from the drop-
down box. Other values can be typed directly into the text box. Auto sets the frequency of markers to a spacing
suitable to the current zoom level.

• Orthogonal or Isometric Grid: Selects the grid to use. Orthogonal place the grid at right angles to the X and Y
axis. Isometric places the grid at 120 ° intervals for guiding isometric drawings.

• Cross-hair: Toggles the orientation of the cross-hairs (right, left, or top) when used with Isometric Snap indicator
lines (see Application Preferences).

3.7.4 Dimensions

The dimension preferences affect how dimensions appear on the drawings. Settings include:

• General scale:

• Text & position:

• Extension lines:

• Dimension lines, arrows & ticks:

• Format units: setting for linear and angular dimensions. These settings are independent of the preference defined
in the Drawing Prefences.

60 Chapter 3. Reference



LibreCAD User Manual, Release 2.2.x.y

Setting Description
General Scale Adjusts the sizes of the text and arrows by the factor provided.
Text size & position
Length factor Adjusts the dimension value by the factor provided. The entity remains the length

as drawn.
Text Style Sets the font used for dimension text.
Text Height Sets the text height, measured in the units defined on the Units tab.
Text alignment Aligns the text parallel and offset to the dimension line or horizontal centered

on the dimension line.
Dimension line gap Sets the space between the dimension line and the dimension text.
Color Set the color of the dimension lines and text.
Extension lines
Offset Gap between entity and dimension extension line.
Enlarge Length of extension line beyond dimension line.
Fixed length Fixed length of extension line measured from the dimension line towards the

dimensioned entity.
Color Extension line color, independent of layer settings.
Width Extension line width, independent of layer settings.
Dimension lines, arrows and ticks
Arrow size Length of dimension (and leader) arrow.
Tick size Length of dimension tick to from end of dimension line in each direction, e.g.

a length of 1 will result in a total length of 2 units. (Anything greater than ‘’0”
will result in a tick instead of a dimension arrow).

Color Tick line color, independent of layer settings.
Width Tick line width, independent of layer settings.
Format units
Linear units (See Length Format under Units above.)
Linear precision (See Length Format under Units above.)
Linear zeros Remove leading, trailing, 0’ and / or 0” from linear dimensions.
Decimal separators Set the decimal separator to a period [.], or comma [,].
Angular units (See Length Format under Units above.)
Angular precision (See Length Format under Units above.)
Angular zeros Remove leading or trailing zeros from angular dimensions.

3.7.5 Splines

The single parameter Number of line segments per spline patch affects the ‘smoothness’ of a spline. The greater the
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value, the ‘smoother’ the spline will be drawn.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

3.8 Customizing LibreCAD’s Interface

In addition to be able to move and reorganize menus and toolbars, LibreCAD can be customized with user-defined
pop-up menus, custom toolbars and alternative “window decorations”.

3.8.1 Menu Creator

The Menu Creator is used to create, modify, or delete custom pop-up menus. The pop-up menu is actived by using
the mouse assigments described below. Open the Menu Creator by selecting Options -> Widgets -> Menu Creator

To create a new menu:

1. Input a name for the menu into the Name drop-down box.

2. Select an action from the left-hand list and use the right arrow (or double-click on the action) to add it to the new
menu (right-hand list).

3. Drag and drop the items on the right-hand list to arrange the actions in the menu.

4. Click the Create button.

To edit an existing menu:

1. Select the menu from the Name drop-down box.

2. Add additional items as described above.

3. To remove an item from the menu, select an action from the right-hand list and use the left arrow (or double-click
on the action) to remove it from the menu.

4. Drag and drop the items on the right-hand list to arrange the actions.
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5. Click the Update button.

To delete an existing menu:

1. Select the menu from the Name drop-down menu.

2. Click the Destroy button.

A custom pop-up menu needs to be assigned to a mouse button to make them accessible:

1. Click the Assign button

2. Enable one or more of the activators (“Double-Click”, “Right-Click”, “Ctrl-Right-
Click”, and / or “Shift-Right-Click”) with a check in the check-box.

3. Click the Save button

3.8.2 Toolbar Creator

Custom toolbars can be created, modified and deleted using the Toolbar Creator. From
the menubar, select Options ->Widgets -> Toolbar Creator.

To create a new toolbar:

1. Input a name into the Name drop-down box

2. Double-click on an action to add it

3. Drag and drop to arrange actions

4. Click the Create button

To modify an existing toolbar:

1. Select the toolbar from the Name drop-down box

2. Double-click to remove actions

3. Drag and drop to arrange actions

4. Click the Create button

To delete an existing toolbar:

1. Select the toolbar from the Name drop-down box

2. Click the Destroy button
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3.8.3 Widget Options

“Widgets” in this context refer to appearance of LibreCAD’s border and title bar,
icons and the statusbar. Select Options - > Widget Options from the menubar to
change these options. The following options are available for:

• General: LibreCAD’s application window decorations (borders, buttons, etc.)
and permits the use of custom style sheets (see below).

• Toolbar: change the Theme and size of the toolbars’ icons.

• Statusbar: change the height of the statusbar and the size of the font used.

To enable an option, place a check in the checkbox and specify the desired option.

3.8.4 Style Sheets

In “Widget Options” you can also choose a style; the style list is dependent on your
operating system and the version of Qt used to build LibreCAD. For example on
Windows 7 and using Qt 5 the list is: (“Windows”, “Fusion”). More information can
be found at http://doc.qt.io/qt-5/stylesheet.html and http://blog.qt.io/blog/2012/10/
30/cleaning-up-styles-in-qt5-and-adding-fusion/

Any style of a “Style Sheet” can be modified, but it is recommended that the “Fusion”
style (Qt 5) be used as a base, because it is intended to be a cross platform style. After setting a style sheet you can edit
it & save and then switch back to LibreCAD and use “Reload Style Sheet” (Ctrl+T).

Tips:

• Start with the example below to obtain and understanding of how style sheet affect the appearance of LibreCAD.

• Look at the examples for “Color” and “Gradient” in the list of property types.

• Check out the widget specific examples at: http://doc.qt.io/qt-5/stylesheet-examples.html

Example

A style sheet can be as simple as:

QMenu { font-size: 16px; }

Or as a more complex example, save the following text as alpha.qss or alpha.txt, and then load the file with Options ->
Widget Options -> Style Sheet:

/* alpha.qss v.01 a modification of the Fusion style */

/* Layer List */
QTableView
{

selection-background-color: #ccffcc;
selection-color: Blue;
font-size: 16px;
font-family: "Arial";

}

QMenu
(continues on next page)
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(continued from previous page)

{
padding: 4px;
font-size: 16px;

}

QMenu::item
{

padding: 2px 25px 2px 20px;
border: 1px solid transparent; /* reserve space for selection border */

}

QMenu::item:selected
{

border-color: darkblue;
background: rgba(240, 255, 255, 150);

}

QMenu::icon:selected
{

border-color: darkblue;
background: rgba(255, 255, 255, 255);

}

QToolBar
{

background-color: rgb(230, 230, 230);
spacing: 3px;
padding: 4px;

}

QToolButton
{

background-color: #eeeeee;
border-style: outset;
border-width: 2px;
border-radius: 2px;
border-color: beige;
font: 12px;
padding: 2px;

}

QToolButton:checked
{

border-color: grey;
background-color: qlineargradient(x1: 0, y1: 0, x2: 0, y2: 1,

stop: 0 #dadbde, stop: 1 #f6f7fa);
}

QToolButton:hover
{

border-color: grey;
background-color: qlineargradient(x1: 0, y1: 0, x2: 0, y2: 1,

(continues on next page)
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(continued from previous page)

stop: 0 #dadbde, stop: 1 #f6f7fa);
}

QStatusBar { background-color: azure;}

QMenuBar { background-color: #fefefe; }

QTextEdit { background-color: honeydew; }

QToolTip { background-color: white; }

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.
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CHAPTER

FOUR

USER GUIDES

The User Guide brings together many other parts of the user manual and will show how to use a variety tools to
create and modify drawings. The user guides provides examples of tasks performed with LibreCAD. The tasks are
generic in the sense that they can be applied to any drawing. The examples provided in the guides build on the previous
examples and when complete will provide a finished drawing that uses many of LibreCAD’s features. Be sure to read
through the Reference section, particularly the Fundamentals, the Drawing Tools and the Snapping sections to obtain
an understanding of the basic operation of LibreCAD and its various tools.

The example drawings in the User Guides use LibreCAD’s default configuration with the exception of the drawing
window’s background color. It has been changed to light grey (#e6e6e6) in Options -> Application Preferences ->
Appearances tab, “Background” color under “Graphic Colors”. The Exercises provide the opportunity to use the
examples to create the sample drawing used in the User Guide.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

4.1 Setting up a Drawing

As with other software; word processors, spreadsheets, etc, there are many ways a user can to setup or configure
preferences for a new document. With LibreCAD, that document is a drawing. Some of the preferences for a drawing
will be governed by drafting conventions, some will be determined by organizational requirements, and others might
just be personal preferences. The drawing’s configuration is largely determined by the Drawing Preferences.

Under normal circumstances, after the initial installation and configuration of LibreCAD, little if any additional config-
uration needs to done before creating a drawing. However, there are a many drawing parameters that can be changed to
suit the user’s requirements and the drawing’s final appearance. The majority of these settings can be left as the defaults
as LibreCAD’s defaults reflect normal drafting conventions and practices, such as the “Text Height” of 2.5 mm / .10”
/ 3/32”, etc. However, these and many other preferences and drawing elements, such as fonts, layer, line thickness and
type, pen colors, etc. can be set to suit users’ requirements.

Some of the key considerations for setting up the drawing include:

• Drawing units

• Page size

• Scale and dimensioning format
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• Layers and “pens”

4.1.1 Drawing Unit

During the initial setup, the default unit of measure was set (defaulting to millimeter). The unit of measure should be
set to the unit most frequently used as it is used for all new drawings and doesn’t need to be changed. If necessary,
the default unit of measure can be changed in the Application Preferences or overridden for a single drawing in the
Drawing Preferences.

4.1.2 Scale and Dimensioning

Setting the scale of a drawing is the easy part, drawings should be created full-scale (1:1)! The zooming abilities of
LibreCAD will make the whole drawing fit in the drawing window or magnify sections to view fine detail. On the other
hand, when producing output the drawing will need to be adjusted in size to fit the page size. Generally, output is a
printed page, but it can also be a pdf, or exported to another image format.

As an example, for an annotated drawing of a floor plan to appear correctly when the drawing is reduced in size, or
scaled down, to print on an “A4” page (210 x 297 mm), the dimension text would need to be proportional to the floor
plan itself prior to being reduced to fit the page. Trying to determine the dimension text size for scaling such a large
object would be tedious at best, but a feature of LibreCAD makes it simple. The “General Scale” is used to adjust the
dimension text, arrows and related parameters to the sizes suitable for the required page size. Both the page size, and
the dimensioning parameters - including the “General Scale” - are configured in the Drawing Preferences.

There are two tabs in Drawing Preferences, “Paper” and “Dimensions”, that require attention for a new drawing.
Specifically the items that need to be addressed are:

1. On the “Paper” tab: Selecting a paper size and orientation will determine the print scale used for final output.
The print scale is used to determine the “General Scale”.

2. On the “Dimensions” tab: Setting the “General Scale” will adjust the dimension text and related parameters to
suit the page size.

The paper format, orientation, and margins to be used is an important to consideration when setting the drawing pref-
erences. The page size is entirely up to the user to determine based on what is available (depending on the printer or
printing service that is being used). While it can be done at anytime, establishing the page size sooner than later will
help determine the “General Scale”.

Tip - Determining Scale

If multiple options are available for the paper size, setting the paper size after drawing the object but prior to dimen-
sioning the drawing will help determine the print scale, the “General scale”, and subsequently the appropriate line
spacing for dimensions. See Dimensioning for additional information.

While any scale can be used when printing a drawing there are commonly used scales for different types of drawings.
Refer to Scales in the appendix for some examples.

Be sure to allow room on the drawing for dimension lines and text when determining the print scale. More details on
printing a drawing are found in the Printing Guide.
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4.1.3 Layers

Using layers to organize drawings and assign pen attributes to the entities on the layer is an important concept. Refer to
Layers in Fundamentals and the Layer List Dock under Dock Widgets in the Reference section for additional details
on using layers.

In LibreCAD, layers are managed using the Layer List Dock. Use the Layer List Dock to add and remove, show and
hide and modify the layer’s attributes. Creating a layer is simple:

1. Click the Add a layer icon .

2. Specify a Layer Name.

3. Optionally specify the Pen Color, Width and Line Type for the layer.

4. Click Ok.

The first layer added defaults to the layer name “noname”, but the name can be replace with any alpha-numeric text.
Additional layers add will adopt the name of the currently selected layer and append a sequential number, but can also
be renamed.

Tip - Using Layers

Layer 0 is a special layer and should not be used for general drawing purposes. Create at least one additional layer for
the drawing.

Prefix the layer name with a sequential number when naming the layer to help sort the layers in the dock list. Layers
are listed in alpha-numeric order, e.g. 1a, 1b, 2a, 2b, etc.

Use “Construction Layer” to create reference geometry to help align other drawing entities.

Layers that have been completed can be locked. Locking layers prevents accidental changes and can improve the
performance when working with very large complex drawings.

Hiding layers while drawing reduces the visual complexity and makes it easier to focus on the current drawing efforts.

4.1.4 Templates

Having to set the unit, page size, layers, etc. each time a new drawing is created can be avoided by using templates.
Templates are prototype drawings that provide a method to save a drawing’s configuration so it does not need to be
defined each time a new drawing is started. A template’s configuration can include the settings defined in the Drawing
Preferences, such as the page size, unit of measure, and the dimensioning format. Templates can also include layers
and other drawing elements such as a border and / or a title block. These settings and drawing elements are inherited
by a new drawings created from the template.

When LibreCAD is launched it creates a new drawing using a default template. The default template is also used when
a new drawing is created within LibreCAD by selecting File -> New or clicking the New icon . The new document
is initially called “unnamed document 1”. Any addition new drawings created while LibreCAD is still open will be
number sequentially; “unnamed document 1”, “unnamed document 2”, and so on. New drawings inherit the template
drawing contents, but do not take the template’s name as a file name. Users are prompted for a file name when saving
the drawing.

User-defined templates can be created to suit various purposes such as different page sizes or orientation, unit of
measure, etc. User-defined templates can be used by selecting File -> New From Template or clicking the New from
Template icon and then selecting the desired template file. See “Creating Templates” below.
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Creating Templates

Templates are created starting with a new drawing, setting the desired Drawing Preferences, and adding any required
drawing elements (e.g. layers, borders, etc). To create a template, starting with a blank drawing:

1. Set the the drawing preferences by selecting Options from the menu bar and then Current Drawing Preferences.

1. On the “Paper” tab set the paper size, orientation and margins as desired.

2. Select the “Units” tab and set the “Main Drawing Unit”. (Note the “Length” and “Angle” settings configure
the status bar format and not the dimensioning format that appear on the drawing.)

3. Click the “Dimensions” tab and adjust the values.

4. Check the remaining tab, “Grid” and “Splines” and adjust those settings if necessary.

5. Click “OK” when done.

2. Add any layers as needed. See Layers for details on using layers and setting the attributes.

3. Add any other drawing elements (borders, title boxes, etc) as required.

4. Save the template as a “dxf”, e.g. “myTemplate.dxf”, to any location with read / write permissions.

LibreCAD supports the use of multiple templates. A user that plans on creating similar drawings may require only a
default template created to suit their needs. Users that create several different types of drawings may desire multiple
templates. For example, templates can be created for each paper size available and / or for each paper orientation.

Default Template

LibreCAD includes a default template, “empty.dxf”, that is installed with the application and found in the resources
directory. It is used initially as the default template for all new drawings. A user-defined template can be used instead of
the default by specifying the new template in the Application Preferences. From the Options menu select Application
Preferences and click on the “Paths” tab. Enter the path and filename of the template to be used as the default. The
specified template is used instead of the default LibreCAD template when the application is launched and for new
drawings.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

4.2 Creating and Editing Entities

Drawing geometric shapes, or entities is familiar to many people that have used drawing and paint programs. As with
many programs, there are a multitude of ways to generate the desired results. LibreCAD is the same - there are many
ways to obtain the same results in a completed drawing - far too many to be able document an example for each one in
a User Guide. For users it is important know what tools are available and how to apply them.

This section of the User Guide brings together many other parts of the LibreCAD manual and will show how to
use a variety tools to create and modify drawings. Be sure to read through the Reference section, particularly the
Fundamentals, the Drawing Tools and the Snapping sections to obtain an understanding of the basic operation of
LibreCAD and its various tools. It is also helpful to understand the different View tools and commands.
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Note: The examples below use both the the command line and the mouse for input. In cases where the command line
is used and additional input is required because of a Tool Option (see Drawing Tools) see the note below the command
text. Where the mouse is the primary form of input, the instructions are provided in a numbered list.

4.2.1 Creating Entities

Creating new geometric entities all use similar methods. Generally, creating an entity requires placement of a minimum
of two points (Well, unless the entity being drawn is a point), or a single point and an additional parameter such as
length or radius. In some case the same result can be obtained using several different methods. For example, drawing
a vertical line can be done via keyboard entry using the command line to select a tool and then define two points with
the absolute or relative Cartesian coordinates:

Using absolute Cartesian coordinates:

li
10,10
10,110
k

The first set of coordinates place the starting point of the line at 10 units horizontally and 10 units vertically from the
origin (0,0). The second set places the end point of the line at 10 units horizontally and 110 units vertically from the
origin (0,0), resulting in a vertical line 100 units long.

Or, using relative Cartesian coordinates:

li
10,10
@0,100
k

The “@” designates relative coordinates. The @0,100 relative Cartesian coordinates places the next point 0 units
horizontally (X axis) and 100 units vertically (Y axis) from the point previously placed at 10,10.

It can also be done with relative polar coordinates:

li
10,10
@100<90
k

The “<” designates a polar coordinate. The @100<90 polar coordinate places the next point 100 units 90 degrees from
the X axis of the point previously placed at 10,10.

The same line can also be drawn using just the mouse:

1. Enabled Snap on Grid .

2. Select the 2 Points line tool .

3. Click at 10,10 (use the Status Bar to locate the absolute coordinates)

4. Click at 10,110

5. Press [Esc] or right-click twice to exit the command.

Other tools can also be used achieve the same result:
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ver
10,10

Note: Ensure the Length is set to “100” and the Snap Point: is “Start” in the “Tool Options” text box.

All the above examples create a line of the same length with the same start and end points. These examples help
illustrate the multiple ways to achieve the same result. The use of a particular tool may be determined by the next
operation that allows the drawing to be quickly extended. A good understanding of the available tools allows the user
to select the appropriate tool for the current operation.

While the above example always start at 10,10, the initial point can be placed anywhere:

li
10,110
10,10
k

Drawings are generally created with multiple lines segments with the end of one segment being the start of another.
Lines can be drawn with multiple connected segments by using the end of the current segment as the starting point
and defining the end point of the next segment. Further, additional points can be defined using any of the methods
previously shown:

li
10,110
10,10
@125,0
@50<90
k

Fig. 1: Example #1

Using the mouse, or another pointing device, along with the snapping tools provide an alternative to using the command
line for creating drawings. As with the command line, there are multiple line tools that can be used to produce the same
result. For example, adding the to the the previous example, a horizontal line can be added using various methods:

1. Click the 2 Points line tool icon .
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2. Enable the Snap on Endpoints and click close to the end of the line at absolute coordinate 10,110.

3. Drag the mouse to the right and, with the Snap on Grid enabled, place a point at absolute coordinate 85,110.
Clicking the mouse should result in a horizontal line ending at precisely at 85,110.

4. Press [Esc] or right-click to exit the command.

Hint: It may be necessary to “Zoom In” to ensure the grid is at the correct resolution to be able to accurately place a
line’s start or end point.

A combination of the 2 Points line tool the Restrict Horizontal tool can also be use as an alternative to Snap on
Grid .

Alternatively, a horizontal line can be added:

1. Click the Horizontal line tool icon . On the “Tool Options” tool bar specify a length of 75 units and the “Snap
Point” at the “Start”.

2. With the Snap on Endpoints enabled click close to the end of the line at absolute coordinate 10,110. Clicking
the mouse should result in a horizontal line ending at 85,110.

3. Press [Esc] or right-click to exit the command.

Fig. 2: Example #2

Being that the end points of the existing lines have been established, the outline can be completed quickly with the
addition of a line:

1. Click the 2 Points line tool icon .

2. Enable the Snap on Endpoints and click close to the end of the line at absolute coordinate 85,110.

3. Drag the mouse to the right and down and place a point close to 135,60. Clicking the mouse should result in a
line angled down and to the right, closing the object’s outline.

4. Press [Esc] or right-click twice to exit the command.

Whichever of the above methods is used, the result should be similar to:

Another option is to draw the line at the desired angle:

1. Click the Angle line tool icon . On the “Tool Options” tool bar specify an Angle of “135”, a Length of “80” units
and the Snap Point at the “Start”.
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Fig. 3: Example #3

2. With the Snap on Endpoints enabled, click close to the end of the line at absolute coordinate 135,60. Clicking
the mouse should result in a line angled up and to the left.

3. Press [Esc] to exit the command.

This option will result in a image similar to what is shown above, but with the diagonal line being a bit too long. The
line can be trimmed to suit (see “Modifying Entities” below):

Fig. 4: Example #3a

Alternate Approach

Fig. 5: Alternate Approach

All of the above examples create the object by drawing individual
lines. A completely different approach is to start with a rectangle:

rec
10,10
@125,100
k
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And then modify it with the “Bevel” tool (see below).

Circles can be added in a similar fashion. It can be drawn with the “Center, Point” tool by specifying the coordinates
for the centre of the circle and of a point on the circumference:

ci
50,70
@0,20
k

A circle of a given size can also be drawn with a known radius:

1. Click the Circle, Radius tool icon . On the “Tool Options” tool bar specify a Radius of “40”.

2. With the Snap on Grid enabled, place the centre of the circle at absolute coordinate 50,70.

3. Press [Esc] or right-click to exit the command.

The drawing should now appear as:

Fig. 6: Example #4

4.2.2 Modifying Entities

There are a variety of tools that can be used to edit and modify existing entities. The tools are found in the Tools ->
Modify menu or as a drawing tool dock widget. These tools allow entities, depending on the type, to be moved, rotated,
scaled, mirrored, lengths increased or decreased, divided (i.e. split), etc. A complete list and descriptions of the tools
can be found in the Drawing Tools - Modify reference section.

Alternate Approach

Fig. 7: Alternate Approach - with the circle

Continuing with the alternate example - starting with a rectangle - the
shape can be modified as required with the Bevel (or “chamfer”) tool.
Its operation is similar to the fillet tool:

1. Click the Bevel tool icon . Ensure with “Trim” is checked, and
“Length 1” and “Length 2” is set at “50” in the “Tool Options”.
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2. As prompted on the Status Bar, select the first entity (the top
horizontal line of the rectangle), and then

3. the second entity (the right vertical line of the rectangle).

4. Press [Esc] or right-click to exit the command.

A rounded corner can be added to the drawing’s the lower left corner with the Fillet tool:

1. Click the Fillet tool icon . Ensure with “Trim” is checked and “Radius” is set at “10” in the “Tool Options”.

2. As prompted in the “Command Line” dock, and on the Status Bar, select the first entity (the bottom horizontal
line of the rectangle), and then

3. Select the second entity (the left vertical line of the rectangle).

4. Press [Esc] or right-click to exit the command.

The drawing should appear as:

Fig. 8: Example #5

Example 3a above left a diagonal line that is too long. The length can be easily trimmed:

1. Click the “Trim” icon

2. Click the top horizontal line. This line is the “limiting entity” that determines where the second line is going to
be trimmed to.

3. Click the line to be trimmed, the “entity to trim” anywhere along the line that is to be kept (below the top
horizontal line).

4. Press [Esc] or right-click to exit the command.

Important: These examples do not provide an example of every tool available in LibreCAD, but is intended to show
the basic operation of some of the drawing and modifications tools. Most of the other drawing and modifying tools work
in a similar manner. Being familiar with the Drawing and Modify tools in the Reference section will help determine
what tool can be used in a particular situation.

These examples also illustrate that there are multiple ways to achieve the same result using a variety of methods. There
is no one best method. The particular method used may depend on the state of the drawing and how existing entities
can be used to build on, or perhaps it is a simple matter of using a preferred drawing / modifying tool.
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Hint:

Working on circle and arc with the Trim command can be confusing, and not working in the way we wish. At certain
constellations it might work, at others it doesn’t.
Circles and arcs have running directions, usually counterclockwise from starting to ending point. For a circle
start/end are both at 0 degree (center in +X direction).
It’s generally easier to cut them up with Divide at the desired points and Delete the unwanted parts.

Changing Attributes and Properties

As shown in the Entities section in Fundamentals, an entity consists of “Pens” (color, width, line type) and “Layers”.
These attributes can be changed using one of two Modify tools:

• Attributes: allows the “Pen” or “Layers” to be modified for one or more entities.

• Properties: allows the “Pen”, “Layers” or geometry of a single entity to be modified.

Both tools operate in a similar fashion and for similar purposes, but there are a couple of key differences. The Attributes
tool allows a change to the attributes to be applied to one or more selected entities while the Properties tool can only
be used for a single entity. In addition, the Properties tool allows the geometry to be edited. The geometry of an entity
will vary be the type of entity. For example a line’s geometry consist of the X and Y coordinates of the endpoints, while
a circles geometry consists of the X/Y coordinates of the centre of the circle and its radius.

Layers and Pens

Change an entity’s layer is similar with both the Attributes and Properties tools.

Using the Attributes to change an entity’s layer:

1. Select the entity (or entities) to be moved to a different layer.

2. From the menu select Tools -> Modify -> Attributes, or click the Attributes icon .

3. In the Attributes dialog, select the desired layer from the drop-down Layer selection box.

4. Click Ok.

Hint: Entities can also be moved from one layer to another by selecting one or more entities and then selecting the new
destination layer in the Layer List dock. To use this method the Modify layer of selected entities, at layer activation
option on the Application Preferences Defaults tab must be enabled.

In a similar manner the color, width and/or line type can be changed:

1. Select the entity (or entities) to be moved to a different layer.

2. From the menu select Tools -> Modify -> Attributes, or click the Attributes icon .

3. In the Attributes dialog, select the desired pen attribute from the drop-down Color, Width and/or Line type selec-
tion box.

4. Click Ok.

The Properties tool operates in a similar manner, but the tool need to be selected before selecting an entity:

1. From the menu select Tools -> Modify -> Properties, or click the Properties icon .

2. Select the entity.
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3. In the Properties dialog, select the desired layer or pen attribute from the appropriate selection box.

4. Click Ok.

Geometry (Properties)

The Properties tool also allows the geometry of an entity to be changed. The geometry is the information used to
describe the entity. The geometry available depends on the type of entity, for example:

Some entities, such as a polyline, have limited properties available that can be changed. Other entities, such as Text,
have many properties that can be changes (including the text itself).

Also, the properties of a specific entity type, e.g. line, does not vary even if the specific tool used to create the entity
varies. A line drawn with the 2 Point line tool will have the same properties as a line drawn with Angle tool.
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Entity Type Drawing Tool Properties
Line 2 points, Angle, Horizon-

tal, etc
Start and end point X/Y coordinates

Circle ”Centre, Point”, 2 Points,
etc

Center point X/Y coordinates, radius

Curve ”Center, Point, Angles”, 3
Points, etc

Center point X/Y coordinates, radius, start/end angle

Ellipse Ellipse (Axis), Ellipse
Foci Point, etc

Center point X/Y coordinates, major/minor axis, rotation, start/end
angle

Polyline Polyline, Rectangle Open or closed
Text Text

Text, font, text height/angle/width factor, alignment, special
characters

MText MText

Text, font, text height/angle/line spacing, alignment, special
characters

Dimension Aligned, Linear, etc Label, special symbol
Blocks Block List, Library

Browser
Insertion point X/Y coordinates, scale X/Y, rotation angle, array
rows / columns and spacing

4.2.3 Drawing Views

LibreCAD supports two drawing views to represent three-dimensional objects:

• Orthogonal: Uses multiple two-dimensional views.

• Isometric: Represents a three-dimensional view in two dimensions.

Orthogonal View

Fig. 9: Doohickey - Orthogonal View with Construction Lines
(blue)

Orthogonal drawings use multiple views to pro-
vide a complete description of an object. Each
view of an orthogonal drawing is parallel to the
axes. Normally a front (the most complex view),
top and right view are added to the drawing. Ad-
ditional views; back, left and bottom can be added
if necessary.

Orthogonal drafting beyond the scope of the Li-
breCAD User Manual, but additional resources
and examples are available in LibreCAD’s wiki or
elsewhere on the web.
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Isometric View

Isometric drawings represent an object on three
axes in a two-dimensional drawing. Isometric
drawings uses the same tools for creating, mod-
ifying and changing attributes as an orthogonal
drawings, but on a grid configuration specific for
an isometric perspective. Set the grid to suit an
isometric perspective on the Grid tab of Drawing
Preferences. Selecting “Isometric Grid” displays
the grid on three axes (X,Y,Z) allowing 3 dimen-
sional drawings to be drawn in a 2D view.

Fig. 10: Doohickey - Isometric View

In addition to setting the grid for isometric draw-
ings, the “Snap indicator lines” on the Appear-
ance tab of Application Preferences can be set to
“Isometric” to assist in with locating entities on
the grid. The “Isometric” crosshairs can be con-
figured to Left, Top or Right to further aid in lo-
cating points on the grid.

Isometric drafting does require some techniques
unique to isometric projection and is beyond the
scope of the LibreCAD User Manual, but ad-
ditional resources and examples are available in
LibreCAD’s wiki or elsewhere on the web.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre
release builds.

The manual is work in progress, and probably
not up to date with the latest build application.

Any help is welcome to add new features and
modifications to this documentation, to close the
gap and make the manual more complete.

4.3 The Command Line

LibreCAD’s command line offers users an alter-
native to using the mouse to select tools and draw.
Using the keyboard to select tools and enter co-
ordinates can provide greater speed and accuracy
when creating drawings. The command line provides other useful features not available using the mouse:

• Multi-command input

• A calculator

The command line is displayed in its own dock widget and consists of three components

• Command prompt.

• Command output window.
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• Button that displays a drop-down menu that includes:

– Toggle Keycode Mode off or on.

– Load a Command file.

– Paste commands.

4.3.1 Command Line Functions

The commands available to use are shown in the Drawing Tools reference. The command line is activated by in a
variety of ways:

1. Start typing any command (e.g. li, rect, etc.) and then [Enter] or the [Space bar].

2. Press the [Space bar], type any command, and then [Enter] or the [Space bar].

3. Press [Ctrl + M], any command, and then [Enter] or the [Space bar].

4. Press [Shift], any command, and then [Enter] or the [Space bar].

5. Press [F1], any command, and then [Enter] or the [Space bar].

6. With the Keycode Mode on, type a two letter command (e.g. li, ci); pressing [Enter] is not required.

When the command line is activated, the prompt above the input text-box (initially showing “Command:” in black text)
turns blue. After typing a command, the prompt will indicate the next input required, such as coordinates or the next
action available.

Pressing [Esc] will cancel the current action and pressing it a second time will cancel the operation. For example,
when using the 2 Points line tool, the first prompt shows “Specify first point” and the second “Specify next point”.
After drawing at least two segments of a line, the next prompt reads “Specify next point or [close/undo]”. LibreCAD
is expecting another set of coordinates to be entered, or the shape (with a minimum of two segments) can be closed or
the last actions can be reversed. close or undo can be entered on the command line, or by clicking on buttons on the
Tool Options toolbar.

For example, to draw a square using the 2 Points line tool from the command line:

Command:
li
Specify first point
0,0
Specify next point
@10,0
Specify next point or [close/undo]
@0,10
Specify next point or [close/undo]
@-10,0
close

Tip - Using the Command Line

• In addition to the comma separated coordinates, relative coordinates can also be entered using the format X..Y,
i.e. typing 10..20 is equivalent to @10,20. For users who prefer entering numbers using the numeric keypad,
using the two decimals is faster than typing the comma.

• The Keycode Mode permits the use of two letter commands and eliminates the need to press [Enter] after typing
the command.

• Pressing the [Space-bar] is an alternative to pressing [Enter] after each command.
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• Typing c or u followed by [Enter] can be used instead of typing close or undo.

• Tab completion can be used on the command line when entering commands. Typing a partial command such
as cir followed by [Tab] will complete the command to circle. If the partial text is not unique to a single
command, the command output will show all the possible commands starting with the text provided. For example,
typing c and pressing [Tab] will list circle, circle2, circle3, circlecr, and cut in the command output.

• Coordinates can be expressed in arithmetic expressions. See Calculator section or Calculator appendix.

The available commands are shown in the Tools reference. Many of the commands have multiple forms. For example
the 2 Points line tools can be selected on the command line by typing l, li, or line. Many tools display the Tool
Options toolbar when selected. Some tools will also provide command line prompts in addition to the Tool Options.
For example the “Parallel” line tools displays:

• a command prompt: Specify Distance <10> or select entity or [through]

• a Tool Options toolbar:

Either can be used can be used to enter new values. The current value on the command line is displayed in angle
brackets as shown above. To change the value from the command line, type the value and press [Enter].

The command output window displays the command history, error messages, and other output (see Calculator below).
The text in the output window can be copied simply by highlighting it. The text is automatically copied to the clipboard
and can be pasted into another document. The output window can be cleared of all text by typing clear in the command
line.

4.3.2 Multi-Command Input

Command input can be combined and entered on a single line by separating the commands and other input with semi-
colons. Entering li;0,0;10..0;0..10;-10..0;c;k on the command line will draw a 10×10 square. A list of com-
mands, separated by a newline (return), can be copied and pasted using Paste multiple commands from the command
line button (lower right corner of the Command Line Dock).

Command input can also be loaded from text files. Entering the commands and other input into a text file separating
each with a newline. For example, create a text file and enter the following commands:

li
0,0
@10,0
@0,10
@-10,0
c
k

Save the file as multiCmd.txt. In LibreCAD select “Load Command File” from the the drop-down menu by clicking
the command line button. Locate the file and click the Open button. The above commands will draw a 10×10 square.

Multi-command input can be assigned to a variable and variables can also contain other variables (they are read recur-
sively):

a=ci;0,0;10
b=ci;10,0;10
c=\a;\b;kill
\c
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Enter each line of the text above on the command line. When \c is entered, two overlapping circles with a radius of 10
units are drawn. The \ character is an escape character that allows the command line to interpret the variable name as
an action. In the above example, \c expands to ci;0,0;10;ci;10,0;10;kill.

A “variable file” can be set to load at startup via Application Preferences -> Paths -> Variable File. Save the first three
line of the above example to a text file and configure the path to the text file. Restart LibreCAD and when \c is entered
at the command line the two circles are drawn.

Note: The # character defines a comment, so everything following this will not be considered by LibreCAD.

4.3.3 Command Aliases

As previously noted many of the commands in LibreCAD have multiple forms. The long untranslated form is
the native command and the short forms are aliases to the long form. For example, l and li are aliases to
line. The aliases are defined in the librecad.alias configuration file. The format of the configuration file is
<alias>[Tab]<command-untranslated>. The default aliases for the 2 Points line appears as:

...
l line
li line
...

Aliases can be added or modified to suit users’ preferences. The file is found in the following locations:

• Linux: $HOME/.local/share/LibreCAD/LibreCAD/librecad.alias

• Windows: C:\Users\ {UserName}\AppData\Local\LibreCAD\librecad.alias

• macOS: $HOME/Library/Application Support/LibreCAD/librecad.alias

Important: Only change the alias and not the long untranslated form.

4.3.4 Calculator

LibreCAD includes a built-in calculator that uses the command line interface. Typing cal on the command line toggles
the calculator mode on and off. With the calculator mode on, math expressions typed on the command line will display
the results in the output window, e.g. typing 1+1 displays 1+1 = 2 in the output window. Some other examples are:

sqrt(3^2 + 4^2) = 5

sin(pi/6) = 0.5

6^5 = 7776

If the cal mode is off, entering a math expression will result in an error message such as Unknown command: 1+1.

A complete list of operators and functions can be found in the appendix.

Note:

The constant Pi is defined in LibreCAD as 3.14159265359.

4.3. The Command Line 83



LibreCAD User Manual, Release 2.2.x.y

It can be used as _pi or pi in arithmetic expressions.
Trigonometric functions use radians. (radians = degrees*pi/180)
To provide angles in degree use affix d; e.g., sin(90d).

More details are in the appendix.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

4.4 The Console Tool

LibreCAD’s console tool gives users certain functionality without having to open the actual GUI version of LibreCAD.
To use it, users need to specify options in their console: librecad [options] .... Running librecad --help or
librecad -h is a basic option that should show a list of all possible options. Running librecad --debug <level>
or librecad -d <level> allows launchin LibreCAD in various debug levels from 0 being in no debug level what-
soever and 6 being the debugging level.

4.4.1 DXF2PDF Tool

LibreCAD allows convertion of DXF drawings to PDF in console without any need to run the GUI. To do so, users can
run librecad dxf2pdf [options] ... in their command line or terminal. This tool has its own set of options and
its own help option which can be obtained by running librecad dxf2pdf –help` or librecad dxf2pdf -h (or simply
librecad dxf2pdf with no options at all).

In a nutshell, users can use it to convert a DXF file or multiple DXF files to a single multi-page PDF or multiple PDFs.
It can be done without specifying any options other than the input filename: librecad dxf2pdf file_name.dxf.
The output file is saved in the executable folder under the name of file_name.pdf. If multiple (N) DXF files are
selecred (librecad dxf2pdf file_name1.dxf file_name2.dxf ... file_nameN.dxf) then N PDF files are
made. It is also possible to convert DXF files to PDF and put the results in a single multipage PDF outfile.pdf
as follows: librecad dxf2pdf -o outfile.pdf file_name1.dxf file_name2.dxf ... file_nameN.dxf.
The same approach can be used if there is a single DXF file input but the outpit filename needs specification.

There are other options available which can be obtained by running librecad dxf2pdf --help and at this stage
include:

-h, --help Displays help.
-v, --version Displays version information.
-a, --fit Auto fit and center drawing to page.
-c, --center Auto center drawing on page.
-k, --grayscale Print grayscale.
-m, --monochrome Print monochrome (black/white).
-p, --paper <WxH> Paper size (Width x Height) in mm.
-r, --resolution <integer> Output resolution (DPI).
-s, --scale <double> Output scale. E.g.: 0.01 (for 1:100 scale).

(continues on next page)
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(continued from previous page)

-f, --margins <L,T,R,B> Paper margins in mm (integer or float).
-z, --pages <HxV> Print on multiple pages (Horiz. x Vert.).
-o, --outfile <file> Output PDF file.
-t, --directory <path> Target output directory.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

4.5 Blocks

Blocks are reusable drawings of commonly used objects such as bolts, furniture, electronic components, title blocks,
etc. Inserted blocks, also called instances or inserts, are composed of geometric shapes (lines, arcs, etc.), but can also
include text and dimensions. Blocks can be created in the current drawing, inserted from the block library, or imported
from a separate drawing file, Once inserted blocks can be used repeatedly within the drawing.

4.5.1 Working with Blocks

There are two dock widgets for managing blocks. The Block List dock for managing blocks within the current drawing
and the Library Browser dock that displays a collection of blocks in the library. Both widgets allow users to insert
blocks into the current drawing, but there are a couple of important differences:

• Blocks inserted from the Block List:

– A block can be placed at a different locations, scale, and/or rotation angle, and also be placed in an array.

– Blocks inserted from the same block in the Block List is called an instance. If a block is inserted from the
same block multiple times all instances of the block are linked. Changes to one instance of the block will
be reflected in all instances of that block.

• Blocks inserted from the Library Browser:

– Each block can be placed at a different location, rotation angle and/or scale.

– Blocks inserted multiple times will create a new instance of the block in the Block List each time it is
inserted. After the initial insertion, the blocks will numbered sequentially (e.g. BlockName, BlockName-0,
BlockName-1, . . . ) The inserted blocks will be independent of each other.

Blocks can also be imported from a separate file and will appear in the Block List. Drawing files imported multiple
times will create a new instances in the Block List and be numbered sequentially as with blocks inserted from the
Library Browser.
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Fig. 11: Example of the Doohickey drawing with blocks, including the page border from the Library Browser (“sheets
-> A4H”) and a block imported from a drawing file (isometric view).
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4.5.2 Using the Block List

Creating a Block

Blocks can be created in the current drawing for use within the drawing. There are two ways to create a block:

• From an existing object:

1. Ensure the all entities for the object to be made into a block are on layer “0”.

2. Select all the entities that make up the object.

3. Click on the Create Block icon .

4. Specify the reference point for the block. The reference point is used to locate the object when it is inserted
into the drawing.

5. Provide a unique name for the new block and click OK. The new block will appear in the Block List.

6. The original object can be deleted from layer “0”. The new block remains available in the Block List.

• From an empty block:

1. Click on the Add an empty block icon . Provide a unique name for the new block and click OK. The new
empty block will appear in the Block List.

2. Select the new block in the Block List and click the Edit the active block in a separate window icon .

3. Ensure layer “0” is selected and draw the object. The drawing’s origin (0, 0) will become the reference
point for the block.

4. Close the new block’s drawing window and the new block will be saved.

Important: Layer “0” has a special significance. It is the default layer for new drawings. More importantly in the
context of blocks, it is equivalent to “no layer”, similar in the way that color “By Block” is equal to “no specified color”
or line type “By Block” is equal to “no specified line type”. Generally layer “0” should only be used when creating
blocks and should be the only layer in a drawing for a block.

Pay particular attention to the Attributes when creating blocks. In addition to the specific attributes, pen attributes
(Color, Width, Line Type) also include “By Layer” and “By Block”.

• Blocks with specific attributes (e.g. color set to blue, width set to 0.18 mm, etc) will retain those attributes when
inserted into a drawing. The block needs to be edited to change any of the attributes.

• Blocks with the attributes set to “By Layer” will adopt the attributes of the layer they are inserted in to. The
block’s attributes will change if the layer’s attributes are changed.

• Blocks with the attributes set to “By Block” will initially adopt the attributes assigned to the layer. The attributes
can be changed with the Attribute tool.
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Inserting Blocks

Blocks can be inserted from the Block List or from the Library Browser (see below). When inserting a block from
the Block List, the Block List Tool Options toolbar is displayed:

• Block can be rotated by the specified Angle and scaled by the Factor.

• A pattern of blocks can be created by specifying the number of columns and rows in the Array and Spacing
between the columns and rows.

To insert a single block:

1. Select a layer for the inserted blocks.

2. Select a block in the Block List.

3. Click on the Insert the active block icon .

4. Set the rotation angle in the Angle field and the scale factor in the Factor field as required. (See Angles in
Fundamentals and “Scale” in Modify tools for more information.) Note: Leave the Array values as “1” and
Spacing values remain as “1.0”.

5. Place the block at the desired location within the drawing.

6. Adjust the rotation angle and scale as needed and place additional copies of the block, or press [Esc] to exit the
command.

Transformations (rotation, scale) and an array can be combined in a single block insertion. The the scale and spacing
is applied to the individual blocks within the array, however the rotation angle is applied to the entire array.

To insert an array of blocks:

1. Select a layer for the inserted blocks.

2. Select a block in the Block List.

3. Click on the Insert the active block icon .

4. Set the rotation angle and scale factor as needed.

5. Set the numbers of columns and rows in Array to create the required pattern.

6. Set the column spacing. This is the distance between the insertion point of two blocks in adjacent columns.

7. Set the row spacing. This is the distance between the insertion point of two blocks in adjacent rows.

8. Place the block at the desired location within the drawing. The insertion point of the array is the insertion point
of the lower-left item in the array (at 0 degrees rotation).

9. Adjust the options as needed and place additional copies of the block, or press [Esc] to exit the command.

Note: When the Angle, Scale, Array size and Spacing are all applied to an array of blocks, the array is created as
follows:

• the scale, number of columns / rows and spacing is applied to the blocks in the array, and then

• the entire array is rotated around the lower left corner of the array.

• The blocks are rotated as the array is rotated and the spacing remains as defined even if the block entities are
scaled.
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Using an array will treat all blocks in the array as a single block instance. Selecting one entity of the array will select
the all blocks in the array. To keep instances separate, insert multiple instances from the block list or create additional
copies with the “Move / Copy” tool or normal edit commands (cut, copy, paste).

Editing a Block

1. Select a block in the Block List and click the Edit the active block in a separate window icon .

2. Edit the block as necessary.

3. Close the block’s drawing window and the block will be saved and all instances of the block will be updated in
the current drawing.

Saving Blocks

Blocks can be saved to a separate file and used in other drawings or added to a user-defined library. To save the block:

1. Select a block in the Block List.

2. Click the Save the active block to a file icon .

3. Select a file location, specify a file name and click Save.

Recommendation

When saving blocks to be added to the library it is recommended that the block’s entities be placed on layer “0” and
layer “0” is the only layer in the drawing. Any additional layers in the block’s drawing will be added to the new drawing
when the block is inserted. The additional layers may have unintended consequences.

4.5.3 Using the Library Browser

LibreCAD includes several categories of blocks in its own library; algorithm, elektro, plan/air_water, plan/architect,
etc. A user-defined library can also be configured in LibreCAD.

Inserting Blocks

Recommendation

When using blocks from the library, insert a single insert from the Library Browser and then insert subsequent in-
stances from the Block List. Inserting the block from the Block List retains the link between instances of the same
block insert. If a block is edited from the Block List, all instances of the block will show the changes.

Only insert multiple inserts of a block from the Library Browser if they are to be independent.

To use blocks from the Block Library, select the block from the tree view and insert it in the drawing. Blocks inserted
from the library can be rotated and scaled through the Library Browser Tool Option toolbar:

The rotation angle and the scale factor behave as they do for a block inserted from the Block List.

To insert a block:
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1. Select a layer for the inserted blocks.

2. Select a block in the Library Browser.

3. Click on the Insert button.

4. Set the rotation angle and scale as needed.

5. Place the block at the desired location within the drawing.

6. Adjust the options as needed and place additional copies of the block or press [Esc] to exit the command.

Adding a User-defined Library

Additional parts and libraries can be added for blocks created by users, libraries downloaded from the LibreCAD wiki
(https://wiki.librecad.org/index.php?title=Part_Libraries) or from other internet resources. LibreCAD can be config-
ured to show user-defined blocks in the library browser in addition to the blocks included with LibreCAD.

The easiest method of installation, which does not require or Linux Root privileges or Windows Administrator
access, is to create a new directory such as “Parts_Library” in the home directory or “Documents” folder. The
path to this directory would be something similar to “/home/{Username}/Parts_Library/” or “C:\Users\ {User-
name}\Documents\Parts_Library\ “. Blocks and libraries can then be placed under the parent “Parts_Library” directory.
The sub-directories will create categories that will appear in the tree view of the Library Browser.

Important: Do not place blocks directly in the parent directory of the parts library. Blocks must be placed in sub-
directories to the parent libraries directory to appear in the Library Browser.

To include the new blocks in the Library Browser tree view, edit LibreCAD’s Application Preferences to add the path
to the directory or folder with the user-defined blocks. From the menus, select Options -> Application Preferences
and select the Paths tab. Type the full path to the part library, e.g. /home/{Username}/PartsLibrary/ or C:\Users\
{Username}\Documents\PartsLibrary\ , into the text-box labelled “Part Libraries” and click “OK”. Click the Rebuild
button on the Library Browser dock and the new libraries will appear in the tree view.

4.5.4 Importing Blocks

Blocks can also be inserted from as a file from other sources. With an open drawing:

1. Select File -> Import -> Block.

2. Locate and select the block drawing file and click “Open”.

3. Set the rotation angle and scale as needed.

4. Place the block at the desired location within the drawing.

5. Adjust the options as needed and place additional copies of the block or press [Esc] to exit the command.

As with inserting a block from the Library Browser, importing a block multiple times will create a new instance of
the block in the Block List each time it is imported, each with a sequentially numbered block name after the initial
block insert. When using blocks from external files the same layer criteria applies (i.e. layer “0”, . . . )
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4.5.5 “Exploding” Blocks

Once a block has been inserted into a drawing, it is treated a
single entity and can only manipulated (moved, scaled, etc.) as
a single entity. Select any one entity within the block selects
the entire block. However, blocks can be disassembled, or ex-
ploded, and once exploded the individual entities making up the
block can be edited. To explode a block:

1. Select a block.

2. Click on the Explode icon .

Note: Once a block has been exploded it is no longer a block and cannot be treated as a single entity. If it is necessary
to recreate the block, refer to Creating a Block above.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

4.6 Annotating a Drawing

A drawing in and of itself provides an image of what the object might look like, but it doesn’t provide a complete
description of the object. Knowing the size of the object is also very important. The size of the drawn object is shown
with measurements, dimensioning, and other textual information to describe the drawn object. Together, dimensions
and text is called annotating a drawing.

Dimensioning an object on a drawing provides the information necessary to be able to interpret the object and ultimately
create it, whether it be a building or a doohickey. Other textual information in the form of notes, symbols, call-outs,
etc. provide further details for the object drawn.

4.6.1 Dimensioning

Dimensions are used to define length, width, height, and/or angle of a line entity, the diameter of circle entity, or radius
of arc entity. A drawing’s dimensions must be:

• Accurate

• Legible

• Complete
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Types of Dimensions

LibreCAD supports the following types of dimensions:

Type Description
Aligned Places the dimension parallel to a line between the two endpoints of the dimension.
Linear Dimension between two points from any angle of interest. The default is 0 (horizontal) and is

changed via Tool Options toolbar.
Horizontal Horizontal Dimension between two points.
Vertical Vertical Dimension between two points.
Radial Radius of an arc.
Diametric Diameter of a circle.
Angular Angle between two lines or linear parts of objects.
Leader Not a dimension per se, but used for notes in drawings.

Complete descriptions of the dimensioning tools and related options are found in Drawing Tools of the Reference
section.

Dimensioning Appearance

A dimension consists of several parts:

The appearance of the dimensions are configured in the Dimensions tab in the Drawing Preferences. As with many
other aspects of a drawing’s setup, there are some generally accepted values for dimensioning:

Dimension Component mm Decimal Inch Fractional Inch
Dimension text height 2.5 .100 3/32
Dimension line gap 1.5 .0625 1/16
Extension line - Offset 1.5 .0625 1/16
Extension line - Enlarge 3 .125 1/8
Arrow size 3 .125 1/8

Note - Adjusting Dimensions for Printing

The size of each dimension component: “Text Height”, “Arrow size”, etc. should be set to the desired “real world”
size in the configuration. That is to say if the desired text height is 2.5 mm when printed, the “Text Height” should
remain set as 2.5 mm. If the drawing is printed full scale (1:1) the dimension text will appear correctly. However if the

92 Chapter 4. User Guides



LibreCAD User Manual, Release 2.2.x.y

drawing is scaled up or down the “General Scale” needs to be adjusted accordingly. The “General Scale” is set to the
inverse of the printing scale. For example, if the printed scale is determined to be 1:4, the “General Scale” should be
set to 4 (4:1).

The minimum spacing between dimension lines needs to be scaled with the drawing. For example, if the drawing is
1:10, the spacing will need to be adjusted to 60 mm between dimension lines and 100 mm from the entity.

Additional information can be found in the Drawing Setup and Printing guides.

Tip - Rules for Dimensioning

A few rules will help to ensure dimensions are accurate, legible and complete:

• There should be only one way to interpret any one dimension.

• Dimension and extension lines should not cross.

• Extension lines and entity lines should not overlap.

• Provide space between dimensions to ensure legibility.

• The view that best shows an entity is the view that should be dimensioned.

• Each entity on the drawing should be dimensioned and dimensioned only once.

• There should be no need to calculate or scale a dimension of an entity.

• A dimension should be referenced to a logical origin point.

• When there are multiple lines of dimensions, the longer dimensions are to be placed outside of shorter ones.

• Except for large circles and arcs, all dimensions should be placed outside the part and spaced 10mm / 3/8” from
the entity.

• Dimension circles with diameters and arcs with radiuses.

• Center lines or center marks should be used on all circles and arcs.

• Extended a circle’s or arc’s center lines and use as extensions line when possible.

• Multiple lines of dimensions are spaced uniformly with a minimum of 6mm / 1/4” between dimension lines (see
note above).

• Use arrow heads or slash marks at the end of the dimension lines.

To improve legiblity, make corrections, or make adjustments after scaling a drawing, dimension labels, dimension lines
and extension lines can be repositioned using Entity Handles.

Dimensioning drawings is beyond the scope of the LibreCAD User Manual, but additional resources and examples
are available in LibreCAD’s wiki or elsewhere on the web.

Dimensioning Example
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Hint:

Modifying a dimension label prohibits the automatic adjustment of the value when the dimension is changed.
There is the placeholder <> for dimension values, that can be used to keep this functionality.
Thus to add a unit to a dimension, you can modify the label via Properties and enter the label text <> mm. This will
show the label as 100 mm, and when the dimension is lengthen, it may show 120 mm automatically.

4.6.2 Leaders

While leaders do not dimension an entity, they are closely related to dimensioning as they are important for annotating
and adding clarity to entities. Leaders provide the ability to place pointers to identify a specific area of interest when
adding a note and linking it to a particulate object. Leaders take their settings from the dimension settings in Drawing
Preferences.

94 Chapter 4. User Guides



LibreCAD User Manual, Release 2.2.x.y

4.6.3 Text

Adding text to a drawing provides addition information; build notes, drawing title and related details, and so forth. Text
can be added using either of the two types of text tools:

“Text”: “MText” (multi-line):

Both tools proved several options for the appearance and placement of text, however a couple are unique to the single-
line Text tool as shown below:
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Option Description Text MText
Font Settings:

• Font
Select font for text X X

• Height
Set font height X X

• Angle
Places text at specified angle X X

• Oblique
Inactive X X

• Width factor
X X

• Default line spacing
Use default line spacing for specified font X X

• Line spacing
X X

Alignment:
Place text aligned to handle:

• top, left/center/right
• middle, left/center/right
• baseline, left/center/right
• bottom, left/center/right

X
X
X
X

X
X

X

• Fit
Places text between specified points while
maintaining set height

X X

• Aligned
Places text between specified points while
maintaining width to height ratio (scales text)

X X

• Middle
Places text with equidistant above and below, left and
right of text as defined by text box

X X

Insert symbol

Insert predefined symbol (Diameter, Degree, Plus /
Minus, At, Hash, Dollar, Copyright, Registered,
Paragraph, Pi, Pound, Yen, Times, Division)

X X

Insert Unicode:

• Page
Select Unicode page to select character from X X

• Char
Select character to insert into text X X

• Insert button
Click button to insert Unicode character into text
input field

X X

Icons:

• Clear text
Clear text field X X

• Load Text From File
Select text file and insert contents into field

X X

• Save Text To File
Save text in text field to file X X

• Edit
Cut / Copy / Paste X X
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LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.

4.7 Completing and Printing

Completed drawings are normally printed to scale and include a border and title block. However, drawings without
a border can be useful for drafts, sketches, exporting to CNC software or a bitmapped image, and so on. In addition
to supporting a large variety of paper sizes; ISO, ANSI, Arch (Architectural), custom, etc., LibreCAD also has the
ability to print drawings across several pages using tiled printing, allowing a drawing to be printed on smaller paper
and assembled into a large format print.

Completing a drawing and making it ready for printing includes a few steps:

• Finalizing the page size and drawing scale,

• adjusting the dimensions and spacing, and

• adding page border and title block as required.

Tip - Using Border and Title Blocks

Adding a border provides a finished look and title blocks include important information for the drawing. Title blocks
vary widely in content and layout, but can include:

• Drawing name

• Project name

• Scale

• Drawing perspective

• Date

• Revision

• Page number

• Paper size

• Name of organization

• Name of draftsperson, approvers, etc

• Others as required
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4.7.1 Print Preview Window

LibreCAD’s Print Preview displays the drawing on a virtual page and allows adjustments to the layout prior to com-
mitting the drawing to paper. To switch to the print preview window, click the Print Preview icon or select File ->
Print Preview:

Fig. 12: LibreCAD’s Print Preview window displaying the Doohickey drawing

Opening the print preview window also displays the Print Preview Tool Options toolbar:

More details for Print Preview Tool Options can be found in the Reference / Toolbars / Tool Options section.

The print preview window shows the virtual page as a white rectangle with a black border and a drop shadow. The black
border represents the paper format and orientation as it is configured on the “Paper” tab of the Drawing Preferences.
If margins are specified on the “Paper” tab, they are shown as a dark grey border.
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4.7.2 Printing

While a drawing can be printed directly by clicking the Print icon or selecting File -> Print, the recommended
approach is to print drawings from the Print Preview window:

Starting with the drawing open in the drawing window:

1. Switch to print preview window by clicking the Print Preview icon .

2. Open the Drawing Preferences (Options -> Current Drawing Preferences) and check the paper layout (“For-
mat”, “Orientation” and “Margins”) for the current drawing: e.g. A4, Landscape, Top, Bottom Left and Right
Margins each at 10. Adjust the layout if necessary and click OK.

3. Click the Fit to Page icon on the toolbar. This will ensure the drawing is scaled to fit the current paper format
and centered on the page.

4. Click the Print icon or select File -> Print.

5. Select the printer on the Print dialogue and confirm the properties by clicking the Properties icon. Adjust the
properties if necessary and then click the Print button.

Tiled Printing

Tiled printing provides the ability to print a scaled drawing that is larger than a printer’s available paper format. Tiled
printing is useful where a drawing needs to be printed at a fixed scale that would otherwise require a large format
printer. The drawing is printed across several pages that can be assembled into a large single document.

Tile printing uses “Format” and “Orientation” found on the “Paper” tab of the Drawing Preferences. It lays out the
pages horizontally and vertically in a grid pattern to form a single large format page to accomodate a scaled drawing.
For example, a portrait A4 page with 2 pages horizontally and 1 vertically would result in a page 420 x 297 mm, or
a landscape A4 in a 2 x 2 pattern would be a page of 594 x 420 mm. Note that both examples use a margin of 0. If
margins are defined, the assembled document is reduced by the margin widths on the common edges of the paper where
they are assembled.

To print a tiled document, starting with the drawing open in the drawing window:

1. Switch to print preview window by clicking the Print Preview icon .

2. Click the Fit to Page icon on the toolbar. This will ensure the drawing displayed correctly in the print preview.
Note that “fixed” needs to be unchecked.

3. Open the Drawing Preferences (Options -> Current Drawing Preferences) and check the paper layout (“For-
mat”, “Orientation” and “Margins”) for the current drawing: e.g. A4, Landscape, Top, Bottom Left and Right
Margins each at 10. Adjust the values if necessary and click OK. (The “Number of Pages” will be calculated
below.)

4. Adjust the scale as desired. Change the print scale by:

1. Selecting a predefined scale ratio from the drop-down, or type the required scale ratio in the text-box and
press [Enter].

2. Lock the print scale by placing a checkmark in the “fixed” checkbox.

5. Click the Calculate number of pages. . . icon on the toolbar. The print preview will show a grid of pages with
the drawing placed in the center. The Number of pages on the “Paper” tab will be updated to reflect the number
of pages shown in the print preview.

6. Adjust the position of the drawing image on the page by repositioning the paper by dragging it as needed (the
drawing stays centered on the screen). Click and hold anywhere in the drawing space and drag the paper to the
desired position. Pressing [Shift] allows only horizontal movements of paper and pressing [Ctrl] allows only
vertical movements.
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7. If necessary, adjust the dimensions “General Scale” and dimension line placement. Refer to Adjusting Dimen-
sions for Printing in Dimensioning and Text for details.

8. Click the Print icon or select File -> Print.

9. Select the printer on the Print dialogue and confirm the properties by clicking the Properties icon. Adjust the
properties if necessary and then click the Print button.

In case when a page has the margins (margins > 0) the print preview takes on a special look in that the margins between
a neighboring pages aren’t shown. It makes possible to represent the printable areas of all pages as one whole area and
to show an undivided drawing. Or, in other words, the print preview looks like the assembled drawing.

Tip - Setting the Margins

Set the margins to the printer’s minimum margins when using tiled printing to maximize the assemble print size.

Next example shows the print preview (left) and the output of tiled printing with the margins (right):

The sequence of the output is from bottom left page to top right page. In the picture above the order of the output is
marked by numbers.

4.7.3 Completing and Printing a Drawing

A finished drawing will include a border / title block and be scaled to suit the paper format and orientation. See Scale
and Dimensioning in the Drawing Setup for more details on determining the suitable scale for a drawing.

Important: These steps assume a drawing that is drawn to full-scale (1:1).

Starting with the drawing open in the drawing window:

1. Switch to print preview window by clicking the Print Preview icon .

2. Click the Fit to Page icon on the toolbar. This will ensure the drawing displayed correctly in the print preview.
Note that “fixed” needs to be unchecked.
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3. Open the Drawing Preferences (Options -> Current Drawing Preferences) and check the paper layout (“For-
mat”, “Orientation” and “Margins”) for the current drawing: e.g. A4, Landscape, Top, Bottom Left and Right
Margins each at 10. Adjust the layout if necessary and click OK.

4. Click the Fit to Page icon on the toolbar. This will ensure the drawing is scaled to fit the current paper format
and centered on the page. Note the scale in the text-box of the print preview toolbar.

5. Adjust the scale using a smaller ratio than the “Fit to Page” scale. For example use “1:2” if “1:1.18” is the
calculated scale. Change the print scale by:

1. Selecting a predefined scale ratio from the drop-down, or type the required scale ratio in the text-box and
press [Enter].

2. Lock the print scale by placing a checkmark in the “fixed” checkbox.

6. Adjust the position of the drawing image on the page by:

1. Clicking the Center to Page icon , or

2. repositioning the paper by dragging it as needed (the drawing stays centered on the screen). Click and hold
anywhere in the drawing space and drag the paper to the desired position. Pressing [Shift] allows only
horizontal movements of paper and pressing [Ctrl] allows only vertical movements.

7. Close the print preview window by clicking the Print Preview icon .

8. If necessary, adjust the dimensions “General Scale” and dimension line placement. Refer to Adjusting Dimen-
sions for Printing in Dimensioning and Text for details.

9. If using a border / title page block, insert the block from the Library Browser:

1. Insert a block from sheets that matches the paper format and orientation, e.g. “A4H” for a landscape A4
page.

2. Set the blocks scale “Factor” suit the scale determined above, e.g. “2” for a drawing scale of 1:2. See
Inserting Blocks in Using the Library Browser for details.

3. “Explode” the border block and add/modify text using the “Properties” tool. Refer to the Modify tools.

10. Switch to the print preview window and check the completed drawing. If necessary, click “Zoom All” and then
“Fit to Page” to align the drawing to the paper.

11. Click the Print icon or select File -> Print.

12. Select the printer on the Print dialogue and confirm the properties by clicking the Properties icon. Adjust the
properties if necessary and then click the Print button.

LibreCAD’s latest build - User Manual

This is the LibreCAD User Manual for latest pre release builds.

The manual is work in progress, and probably not up to date with the latest build application.

Any help is welcome to add new features and modifications to this documentation, to close the gap and make the manual
more complete.
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FIVE

APPENDICES

5.1 Online Resources

LibreCAD main website: https://librecad.org/

5.1.1 Download Installation Packages

There are 2 types of installation packages depending on code maturity: first the official release, then the last build. A
build is an interim state of LibreCAD development with additional improvements yet not mature enough to provide a
new release. Note that a build may be less stable than an official release.

Operating System URL

MS Windows:
- GitHub

https://GitHub.com/LibreCAD/LibreCAD/releases

OSX:
- GitHub

https://GitHub.com/LibreCAD/LibreCAD/releases

Linux Distributions:
- AppImage (runs on most Linux)
- Debian/Ubuntu (Stable)
- Debian/Ubuntu (UnStable)
- Arch Linux
- Fedora
- Gentoo
- OpenSUSE

https://GitHub.com/LibreCAD/LibreCAD/releases
https://packages.debian.org/stable/graphics/librecad
https://packages.debian.org/unstable/graphics/librecad
https://www.archlinux.org/packages/community/x86_64/librecad/
https://apps.fedoraproject.org/packages/librecad
https://packages.gentoo.org/packages/media-gfx/librecad
https://software.opensuse.org/package/librecad
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5.1.2 Getting Help

There are many other resources for getting help with LibreCAD:

• LibreCAD forum: http://forum.librecad.org/

• LibreCAD Wiki: https://dokuwiki.librecad.org/

– FAQ: https://dokuwiki.librecad.org/doku.php/usage:faq

– Tutorials: https://dokuwiki.librecad.org/doku.php/usage:tutorials

– Part Libraries: https://wiki.librecad.org/index.php/Part_Libraries

5.1.3 Reporting Bugs

You can help with the improving LibreCAD. Please report any bugs at LibreCAD’s GitHub Issues page: https://GitHub.
com/LibreCAD/LibreCAD/issues

5.2 Line Attributes

5.2.1 Common Line Widths

The following table provides suggested line widths for ISO A4/A3/A2 or ANSI A/B/C paper sizes:
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Line Weights Pen Size (mm) Purpose Recommended
Extra Thin 0.00, 0.05, 0.09

Hidden lines
Hatching
Reference line

0.00 mm

Thin 0.13, 0.15, 0.18,
0.20, 0.25 Outlines

Center lines
Dimension lines
Leader and extension
Phantom lines
Grid lines
Text

0.18 mm

Medium 0.30, 0.35, 0.40,
0.50 Hidden lines

Text normal (0.30 mm)
Text - sub-headings (0.50 mm)
Visible object outlines

0.35 mm

Thick 0.70
Cutting lines
Match lines
Section lines
Text - titles/major headings
Viewing planes

0.70 mm

Extra Thick 1.00
Title sheet border

Note: Pen sizes shown in bold are ISO standard sizes.
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5.2.2 Line Types
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Image can be printed 1:1 using scale shown at bottom.

5.3 Hatches

Unless shown otherwise, hatch patterns are shown at 1:1 scale (1x)
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5.4 Fonts

Font Name Font Filename Font Type Tech-
nical
(*)

Sample

amiri-regular amiri-regular.lff Serif
azomix_i azomix_i.lff Sans Serif X
azomix azomix.lff Sans Serif X
cursive cursive.lff Sans Serif X
cyrillic_ii cyrillic_ii.lff Sans Serif X
gothgbt gothgbt.lff Blackletter / Gothic
gothgrt gothgrt.lff Blackletter / Gothic
gothitt gothitt.lff Blackletter / Gothic
greekc greekc.lff Greek Lettering
greekcs greekcs.lff Greek Lettering
greek_ol greek_ol.lff Greek Lettering
greekp greekp.lff Greek Lettering X
greeks greeks.lff Greek Lettering X
iso3098_i iso3098.lff Sans Serif X
iso3098 iso3098_i.lff Sans Serif X
iso iso.lff Sans Serif X
italicc italicc.lff Serif
italiccs italiccs.lff Serif
italict italict.lff Serif
kochigothic kochigothic.lff Sans Serif
kochimincho kochimincho.lff Serif
kst32b kst32b.lff Sans Serif X
lc_opengost-
ar

lc_opengost-ar.lff Sans Serif X

lc_opengost-
br

lc_opengost-br.lff Sans Serif X

OpenGostTypeA-
Regular

OpenGostTypeA-
Regular.lff

Sans Serif X

OpenGostTypeB-
Regular

OpenGostTypeB-
Regular.lff

Sans Serif X

romanc romanc.lff Serif
romancs romancs.lff Serif
romand romand.lff Sans Serif
romanp romanp.lff Serif
romansi romansi.lff Sans Serif X
romans romans.lff Sans Serif X
romant romant.lff Serif
scriptc scriptc.lff Formal Script
scripts scripts.lff Formal Script
simplex simplex.lff Sans Serif X
standard standard.lff Sans Serif X
syastro syastro.lff Symbol
symap symap.lff Symbol
symath symath.lff Symbol
symbol symbol.lff Symbol
symbol_misc1 symbol_misc1.lff Symbol

continues on next page
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Table 1 – continued from previous page
Font Name Font Filename Font Type Tech-

nical
(*)

Sample

symbol_misc2 symbol_misc2.lff Symbol
symeteo symeteo.lff Symbol
symusic symusic.lff Symbol
unicode unicode.lff Sans Serif X

*: These fonts are composed of single lines and are suitable for technical drawings.

ASCII character set render in each font:
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5.5 Common Drawing Scales

5.5.1 Architect’s Scale (SI)

Drawing Scale Common Use
1:1 Mockups / Samples / Small details
1:2 Construction details
1:5 Construction details
1:10 Construction details / Wall sections
1:20 Building sections
1:50 Building sections / Floor plans / Elevations
1:100 Floor plans / Elevations
1:200 Floor plans / Elevations / Site plans
1:500 Site plans
1:1000 Area plans

5.5.2 Architect’s Scale (Imperial)

Drawing Scale Ratio Common Use
Full scale 1:1 Mockups / Samples / Small details
3=1-0 1:4 Small details
1 1⁄2=1-0 1:8 Small details
1=1-0 1:12 Small details / Construction details
“3⁄4=1-0” 1:16 Construction details / Wall sections
“1⁄2=1-0” 1:24 Building sections
3⁄8=1-0 1:32 Wall sections / Building sections
1⁄4=1-0 1:48 Building sections / Floor plans / Elevations
“3⁄16=1-0” 1:64 Floor plans / Elevations
“1⁄8=1-0” 1:96 Floor plans / Elevations / Site plans
“3⁄32=10” 1:128
“1⁄16=1-0” 1:192 Site plan

5.5.3 Engineer’s scale (Imperial)

Drawing Scale Ratio Common Use
1=10-0 120 Details
1=20-0 240 Details / Working plans
1=30-0 360 Working plans
1=40-0 480 Working plans
1=50-0 600 Working plans
1=60-0 720 Working plans
1=100-0 1200 Area plans
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5.6 Languages

LibreCAD supprts these languages to varying degrees:

Albanian German Portuguese (Brazil)
Arabic Greek, Modern (1453-) Romanian
Basque Hindi Russian
Catalan; Valencian Hungarian Slovak
Chinese (China, Simplified) Indonesian Slovenian
Chinese (Taiwan, Traditional) Italian Spanish (Argentina)
Czech Japanese Spanish (Mexican)
Danish Korean Spanish; Castilian
Dutch; Flemish Latvian Swedish
English (Australia) Macedonian Tamil
Estonian Norwegian Turkish
Finnish Panjabi; Punjabi Ukraine
French Polish
Galician Portuguese

Note: For more information about translations, to see the current status or to contribute, refer to https://translate.
librecad.org/projects/librecad/

5.7 Systems of Measurement

LibreCAD supports a large number of measurement systems/units:
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Unit Abbr. System Equivalences Uses (*)
Inch in Imperial 3 barleycorns Widely used in the United States, Canada, and the

United Kingdom.
Foot ft Imperial Size 46 (EU) shoe

size
Still widely used in the United States, Canada, and
the United Kingdom.

Mile mi Imperial 0.2756 of a Dutch
mile

Used way too often in other than a ‘’international
mile”.

Millimeter mm SI More than 25 in an
in

Vanilli’s favorite

Centimeter cm SI
Meter m SI nm
Kilometer km SI Sigh, SI units are not funny. . .
Microinch µin Imperial
Mil mil Imperial 1/1000 of an inch Replaced with ‘’thou” (but not ‘’you”).
Yard yd imperial 3 foots Measure ale!
Angstrom å one ten-billionth of

a meter
Zoom to a parsec - I dare you.

Nanometer nm SI 1 E9 m the UoM formerly known as the ‘’millimicrome-
tre” and ‘’mµ”.

Micron µm SI Really is a ‘’micrometer”, but not to be confused
with a ‘’micrometer screw gauge”.

Decimeter dm SI 0.1 meter
Decameter dam SI 10 meters ‘’dam”, don’t be juvenile.
Hectometer hm SI 100 meters Should be funny, but why?
Gigameter Gm SI 1,000,000,000 me-

ters
That’s one beeellion meters.

Astro au, ua or
AU

astro-
nomical
unit

also a ‘’a South Korean boy band”.

Lightyear ly astro-
nomical
unit

63241 au First name ‘’Buzz”.

Parsecs pc astro-
nomical
unit

206264.806247096
astronomical units

er, big. What else can one say? Made popular by
James T.

*: Obtained from Wikipedia and Wiktionary and wildly interpreted by the author of this page.

5.8 Calculator Operators and Functions

Typing cal at the command line will toggle the calculator mode on and off.

Hint:

Trigonometric functions expect angles in radians, they are identifiable by the function parameter (a) in the table!
(radians = degrees*pi/180)
This is not very comfortable for humans, but there is a simple solution to pass angles in degrees.
Append the affix d to the degree value; thus, sin(90d) is a valid expression and will return the sinus of 90°.

As the calculator accepts arithmetic expressions and constants, this term will work too: sin(90*pi/180)

114 Chapter 5. Appendices



LibreCAD User Manual, Release 2.2.x.y

The part 90*pi/180 will be internally calculated and results in 1.57079632679, which is 90° in radians.

And of course, arithmetic expressions can be used for other function parameters too, e.g. to convert imperial to metric
values and vice versa.

Functions

Name Function / Operation Usage
+ addition x+y
- subtraction x-y
* multiplication x*y
/ division x/y
^ raise x to the power of y x^y
sin sine function sin(a)
cos cosine function cos(a)
tan tangens function tan(a)
asin arcus sine function asin(a)
acos arcus cosine function acos(a)
atan arcus tangens function atan(a)
sinh hyperbolic sine function sinh(a)
cosh hyperbolic cosine cosh(a)
tanh hyperbolic tangens function tanh(a)
asinh hyperbolic arcus sine function asinh(a)
acosh hyperbolic arcus tangens function acosh(a)
atanh hyperbolic arcur tangens function atanh(a)
log2 logarithm to the base 2 log2(x)
log10 logarithm to the base 10 log10(x)
log logarithm to base e (2.71828. . . ) log(x)
ln logarithm to base e (2.71828. . . ) ln(x)
exp e raised to the power of x exp(x)
sqrt square root of a value sqrt(x)
sign sign function -1 if x<0; 1 if x>0 sign(x)
rint round to nearest integer rint(x)
abs absolute value, negatives become positive abs(x)
min min of all arguments min(x, y, . . . n)
max max of all arguments max(x, y, . . . n)
sum sum of all arguments sum(x, y, . . . n)
avg mean value of all arguments avg(x, y, . . . n)

Constsants

Name Alias Constant Value
_pi pi The number 3.141592653589793238462643
_e Euler’s number 2.718281828459045235360287

Hint: Behind the scenes LibreCAD uses the muParser library for the command line and many input boxes. So the
above information describes basically the features of muParser, which are implemented in LibreCAD.

For advanced users or the courious ones, you can read more about muParser on the inventors website:
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Reference: https://beltoforion.de/en/muparser/index.php#idStart

But, be aware, that LibreCAD probably does not use the latest version of muParser. Also, it is not fully implemented.
The muParser library has much more capabillities than LibreCAD uses.

5.9 Building from Source

Building from the source code allows users to run the cutting-edge version of LibreCAD that includes bug fixes and
possibly new features. LibreCAD can be compiled to run on multiple operating systems; Linux, Microsoft Windows,
and macOS. The process differs depending on the OS.

Important: The instructions are as complete as possible to provide the necessary steps to allow any
user to build LibreCAD from the source code, however some understanding of the operating system and
installation of the required tools and dependencies is required. The instructions are intended for users
that want to try the cutting-edge version of LibreCAD and are not intended to replace the instructions for
building packages or contributing to the LibreCAD project.

If you are a developer and want to contribute to LibreCAD see the Contributing section in the Appendices.

The tools and dependencies required to build LibreCAD are:

• C++ compiler and related utilities

• Qt development framework

• Boost C++ source library

• muParser math expression parser library

• git distributed version control system (optional)

5.9.1 Download the Source Code

The source code is hosted on GitHub and is common to all three operating systems. It can be download as a “zip”
archive or cloned using “git”. These instructions use the download option.

Go to the LibreCAD GitHub page to download the source code. On the <> Code tab, click on the “Clone or Download”
button and then click “Download ZIP”. Save the zip file; LibreCAD-master.zip.

Cloning is suggested if users want to build LibreCAD more frequently as the source code is updated. More information
about GitHub, git tools, and creating a local source code repository can be found on LibreCAD’s Developer’s wiki.

5.9.2 Building on Linux

Note: These instructions are for building LibreCAD on Debian and other derivatives. Further instructions for building
LibreCAD on other Linux distributions (openSUSE, Red Hat, FreeBSD) and generic Unix can be found in LibreCAD’s
GitHub Developer’s wiki in the Build from source section.
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Install Tools and Dependencies

Install the required tools and libraries (compiler, Qt, boost, muparser, etc.):

$ sudo apt install g++ gcc make qtbase5-dev libqt5svg5-dev qttools5-dev\
qtchooser qttools5-dev-tools libboost-dev libmuparser-dev librsvg2-bin\
libfreetype6-dev libicu-dev pkg-config

You also have to either install the qt5-default package; apt install qt5-default, or use qtchooser prior to running
qmake; qtchooser -qt5.

Build LibreCAD

Create a development directory for the source code and related libraries; e.g ~/dev/. Extract the contents of the source
code zip file, LibreCAD-master.zip, to the development directory. When complete, a complete copy of the source code
will found in the ~/dev/LibreCAD-master directory. Compiled LibreCAD with the following commands:

$ cd ~/dev/LibreCAD-master/
$ qmake -r
$ make -j4

If the build is successful an executable is created, ~/dev/LibreCAD-master/unix/librecad, and LibreCAD can be
launched by typing:

$ ./unix/librecad &

5.9.3 Building on Windows

Building LibreCAD on Windows is a little more involved and requires a few additional steps. Please read these instruc-
tions carefully.

Note: Detailed instructions for building LibreCAD on Windows, including instructions for building LibreCAD in
Visual Studio 2013 and newer, can be found on the GitHub Developers wiki (https://github.com/LibreCAD/LibreCAD/
wiki) in the Build from source section.

Install Tools and Dependencies

Qt Framework

The Windows version of Qt includes both the required framework library and the compiler. Download the open source
version of the Qt Online Installer from Qt download <https://www.qt.io/download>. Launch the installer accepting
the defaults. Install Qt to the default path prompted by the installer, e.g. C:\Qt. On the Select Components page expand
the tree view under the most recent version of Qt, e.g. Qt 5.12.3, and select the latest version of the MinGW compiler;
MinGW 7.3.0 (32-bit or 64 bit as required). No other components are needed.
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Boost

Download the current release of the boost library “zip” file from Boost downloads <https://www.boost.org/users/
download/>. Click on the link to download the current Windows library, e.g. boost_1_70_0.zip and save the file.

muParser

muParser is not required to build LibreCAD on Windows as the library is now included with the LibreCAD source
code.

Build LibreCAD in Qt Creator

Create a development folder for the source code and related libraries, e.g C:\dev\. Extract the contents of the source code
zip file, “LibreCAD-master.zip”. When complete, a copy of the source code will found in the C:\dev\LibreCAD-master
folder.

Extract the boost library the files to the development folder. Note the folder name the boost library was extracted to,
e.g. C:\dev\boost_1_70_0\.

After extracting the LibreCAD source code, open the custom.pro file in .\LibreCAD-master\librecad\src
under the development folder and add the following two lines (note the forward slashes in the path.):

BOOST_DIR = C:/dev/boost_1_70_0/
BOOST_LIBDIR = C:/dev/boost_1_70_0/

After completing the required edit, launch Qt Creator (Start -> All Programs -> Qt -> Qt Creator) and open the
librecad.pro project file from the LibreCAD source folder (File -> Open File or Project and go to C:\dev\LibreCAD-
master\). The project should open to Configure Project. Ensure a “kit”, e.g. Desktop Qt 5.12.3 MinGW 32-bit is
checked and click the Configure Project button. It will take a few moments for the project to open and parse.

Click the Project icon on the left side of the Qt Creator window. Disable the “Shadow build” option in the Debug,
Profile and Release build configurations. Each build configuration can be selected from the drop down below Build
Settings. Save the project (File -> Save All).

With the configuration complete, run the build process in Qt Creator by clicking the Build icon on the lower left side.
If the build is successful an executable is created: .\LibreCAD-master\windows\librecad.exe.

Important: Several Dynamic-link libraries (DLL) are required to run LibreCAD. The DLLs are found in the
C:\Qt\5.12.3\mingw73_32\bin folder (or mingw73_64) and need to be copied to the same directory as the executable
(or included in the path). The DLLs are:

• libgcc_s_dw2-1.dll

• libstdc++-6.dll

• libwinpthread-1.dll

• Qt5Core.dll

• Qt5Gui.dll

• Qt5PrintSupport.dll

• Qt5Svg.dll

• Qt5Widgets.dll
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Once the DLLs have been copied to the executable folder, LibreCAD can be launched by Clicking Start -> Run and
typing:

> C:\dev\LibreCAD-master\windows\librecad.exe

5.9.4 Building on macOS

There are a few options for compiling LibreCAD for the macOS. This method uses the LLVM Compiler Infrastruc-
ture and the Homebrew Package Manager. Refer to the Github Developer’s wiki for additional methods.

Install Tools and Dependencies

From the command prompt, download and install Homebrew with:

/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/
→˓install.sh)"

Further details are available on the Homebrew website.

Install the latest versions of boost and qt5 with Homebrew:

brew install boost qt5

Build LibreCAD

Create a development directory for the source code and related libraries; e.g ~/dev/. Extract the contents of the source
code zip file, LibreCAD-master.zip, to the development directory. When complete, a complete copy of the source code
will found in the ~/dev/LibreCAD-master directory. Change to the source code directory with:

cd ~/dev/LibreCAD-master/

Next build LibreCAD by running qmake. Note that during the installation step above, brew install qt5, the binaries
have not been linked to /usr/local. In order to use qmake, use the full path:

/usr/local/Cellar/qt5/5.7.0/bin/qmake librecad.pro -r -spec macx-clang

To compile the application, at the prompt run:

make -j4

If the previous steps were successful, an application named LibreCAD.app will be in the build directory. Run it at the
command prompt by typing either:

open LibreCAD.app, or
LibreCAD.app/Contents/MacOS/LibreCAD

Note: The macOS build section been revised, but not tested. Please provide any feedback on the build process on the
LibreCAD forum: http://forum.librecad.org/Help-wanted-to-build-on-MacOS-td5717273.html
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5.10 Contributing

5.10.1 Code

If you are a developer, outstanding in C++, or a beginner we can use all the help. With a bit of determination, the
IRC channel, Zulip chat and the Libre-CAD-dev mailing list, we can help you get started and making progress. The
source code is hosted on GitHub (https://github.com/LibreCAD/LibreCAD). A good starting point for developers is
the LibreCAD Developer’s wiki on GitHub (https://github.com/LibreCAD/LibreCAD/wiki/Git-and-GitHub).

The Online Resource section provides links to further information on downloading and building LibreCAD.

5.10.2 Documentation

Developers are usually bad in making documentation, so if you like writing documentation your involvement in devel-
oping the User Manual would be greatly appreciated.

The documentation is hosted by Read the Docs. The most recent version of LibreCAD’s User Manual can be found at
https://librecad.readthedocs.io/. As with the source code, the documentation source is hosted GitHub (https://github.
com/LibreCAD/docs). The documentation is created using a markup language called reStructuredText (Refer to
http://docutils.sourceforge.net/rst.html). For those interested in contributing to the documentation, refer to LibreCAD
Documentation wiki on github (https://github.com/LibreCAD/docs/wiki).

5.10.3 Translation

Help localize LibreCAD, we currently support over 30 languages. Our translation server is at https://translate.librecad.
org/. You can contribute to a language already started or or request the creation of a translation for a new language in
the forum in the LibreCAD-translate section.

5.11 License

5.11.1 LibreCAD and the GPLv2

LibreCAD is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License
version 2 (GPLv2) as published by the Free Software Foundation.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the
implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
Public License for more details.

The GPLv2 can also be found in the licenses folder as gpl-2.0.txt.

• <https://github.com/LibreCAD/LibreCAD/tree/master/licenses>

• <http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt>
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History

QCAD community edition version 2.0.5.0 was released under the GPLv2. > Copyright (C) 2001-2003 RibbonSoft.
All rights reserved.

• <http://www.ribbonsoft.com>

LibreCAD is a fork of QCAD community edition version 2.0.5.0; therefore, any modifications of or additions to the
program are also released under the GPLv2.

The project’s first commit on Github was Aug 16, 2010.

• <http://librecad.org/>

• <https://github.com/LibreCAD/LibreCAD>

Rights holders of the code

Some of the following may be composites of multiple copyright notices.

Copyright (C):

• 1999, 2001, 2007 Frank Warmerdam

• 2001-2003 RibbonSoft. All rights reserved.

• 2004-2014 Ingo Berg

• 2010, 2011, 2012, 2015 R. van Twisk (librecad@rvt.dds.nl)

• 2011-2015 Dongxu Li (dongxuli2011@gmail.com)

• 2011-2015 José F. Soriano (rallazz@gmail.com)

• 2014 cgrzemba (cgrzemba@opencsw.org)

• 2014 Pavel Krejcir (pavel@pamsoft.cz)

• 2014-2015 Christian Luginbühl (dinkel@pimprecords.com)

• 2015 A. Stebich (librecad@mail.lordofbikes.de)

• 2015-2016 ravas (github.com/r-a-v-a-s)

Rights holders of the fonts

Copyright (C):

• 2002 Yoshimune Kobayashi (cfg47520@syd.odn.ne.jp)

• 2004 by Saka.N (Saka.N.06@b3.mnx.ne.jp)

• 2010-2013 Khaled Hosny (khaledhosny@eglug.org)

• 2011, 2012 Rallaz (rallazz@gmail.com)

• 2014 stranger573 (stranger573@mail.ru)

• 2015 AZO (typesylph@gmail.com)
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Rights holders of the art

Copyright (C):

• 2011 Diego Alejandro Torres M. “Daltom Designer” (http://daltom.2082studio.com)

• 2011 Pablo Ramrez Alem (www.librecad.com.ar)

Honorable mention

These are known contributors whose copyright notice could not be found.

• Claude Sylvain | <csylvain@electro-technica.com>

• Scott Howard | <showard@debian.org>

• Lisandro Damián Nicanor Pérez Meyer | <perezmeyer@gmail.com>

A list of contributors to the LibreCAD repository can be found at: <https://github.com/LibreCAD/LibreCAD/graphs/
contributors>

5.11.2 Licenses of bundled content

The LibreCAD source code is released as a whole under the GPLv2. The following refers to the licenses used by these
resources, when they were released independently from LibreCAD.

The SVG icons in librecad/res/icons were all released under the CC0 license.

• <https://github.com/LibreCAD/Resources>

• <https://creativecommons.org/publicdomain/zero/1.0/>

libdxfrw was released under GPLv2 “or any later version”.

• <https://sourceforge.net/projects/libdxfrw/>

muParser was released under the MIT license.

• <http://beltoforion.de/article.php?a=muparser&hl=en&p=licence>

Shapelib was released under a “MIT Style” license or LGPLv2.

• <https://github.com/LibreCAD/LibreCAD/tree/master/plugins/importshp/shapelib>

The AZOmix fonts were released under the KST32B version 2.0 license.

• <https://github.com/LibreCAD/LibreCAD/blob/master/licenses/KST32B_v2.txt>

• <http://domisan.sakura.ne.jp/article/cadfont/cadfont.html>

The Amiri font was released under the Open Font License.

• <http://www.amirifont.org/>

• <https://github.com/khaledhosny/amiri-font/blob/0.108/OFL.txt>

The Hershey Fonts were originally created by Dr. A. V. Hershey while working at the U. S. National Bureau of Stan-
dards. The format of the Font data in this distribution was originally created by:

James Hurt Cognition, Inc. 900 Technology Park Drive Billerica, MA 01821
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